General :  K-Meleon Forum
General discussion about K-Meleon. 
Problem with www.rapidshare.com
Posted by: forever
Date: September 28, 2010 04:34AM

hi

KM 1.6 displays it correctly but unfortunately 1.5.4 doesn't

is there anything i can do to fix that?

Any Ideas would be great

thx

edit: a friend told me it could be a html5-problem



Edited 2 time(s). Last edit at 09/28/2010 04:40AM by forever.

Options: ReplyQuote
Re: Problem with www.rapidshare.com
Posted by: ndebord
Date: September 28, 2010 05:43AM

Quote
forever
hi

KM 1.6 displays it correctly but unfortunately 1.5.4 doesn't

is there anything i can do to fix that?

Any Ideas would be great

thx

edit: a friend told me it could be a html5-problem

forever,

Can you give us a link to the exact problem?

(I'm at the main page right now with KM 1.5.4 and can't tell where the problem may be.

Tks.

N

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: siria
Date: September 28, 2010 06:36AM

What a mess... Just click to upload something and the layout gets chaotic.
And they throw a "Get a new browser!" error if javascript is blocked, whether the browser is old or new doesn't matter at all! *rolleyes*

At least uploading DOES work, but things are mixed up and covering each other. The upload button is not inside or next to the upload box, but hovering far away, one must click on the big upload-globe. Since it seems to be basically functioning, I'm optimistic a css workaround might help, and there sure are already some userstyles out there!

Though I know very little about CSS but couldn't help playing and experimenting a little, and the result is embarassing and just a tiny bit better, but oh well, until someone posts a 'real' fix, this is perhaps better than nothing *blush* (Can be added to the adblock-stylesheet, doesn't need restart for changes)

/* ========== Rapidshare-mess / For KM1.5 only, not 1.6!! =============
@-moz-document domain(rapidshare.com) {
#head h1 a {
background: none !important;
}
.uploads {
background: yellow !important;
height: 300px !important;
top: 200px !important;
}
.curved , #mainnav {
float: none !important;
font-weight: bold !important;
font-size: 20px !important;
}}

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: forever
Date: September 28, 2010 06:39AM
Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: disrupted
Date: September 28, 2010 10:26AM

forever, this is not fixable by css. the uploadpanel placement is controlled by js.. the footer and few kinks are indeed css but js controls their functions. surely we can reorganise everything with css but there's no point as that will be like making something pretty but still dysfunctional, the upload panel will not anyways .. this is not like youtube or facebook misplacements that can be fixed with css because their js is interpreted normally in gecko 1.8.. but that's not the case with rapidshare where the js itself is not supported by gecko 1.8, additionally css3(html5) is heavily used in rapidshare and that causes many display errors in 1.5 that are simply not fixable using the css commands in 1.8

in any case it's not really a kmeleon 1.5.x bug..the gecko 1.8 engine is too old for rapidshare now

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: forever
Date: September 28, 2010 03:36PM

thank u disrupted.

so i will use another browser for that until KM 1.6 is final :-(

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: guenter
Date: September 28, 2010 04:47PM

Quote
forever
so i will use another browser for that until KM 1.6 is final :-(

Warum einen anderen? 1.6 ist weit. Weitgehend lokalisieren geht auch leicht.

mfG



Edited 1 time(s). Last edit at 09/28/2010 04:49PM by guenter.

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: forever
Date: September 28, 2010 07:42PM

ach dann hab ich den wieder nicht auf deutsch ;)

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: disrupted
Date: September 29, 2010 01:09AM

it seems to be working now, either you have caught them early during a prototype test or someone there figured it's probably not a good idea to block out ie6/7

the new code appears to be properly detecting features js+css3 support and uses an alternative that strips out html5-specifics for older engines.

if it still displays as before, try using this user agent(tools>user agent>custom)
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0)
or
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 6.1)

both those strings should restrict it to css2 and simple js only
it's probably best to avoid a firefox ua spoof

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: forever
Date: September 29, 2010 02:31AM

thanks for the news
now everythings's working fine

perhaps they changed their website like they are always changing things ;)

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: guenter
Date: September 29, 2010 05:09AM

Gut, dass rapidshare.com es gefixt hat smiling smiley

Hast für sie Versuchskaninchen gemacht.

Quote
forever
ach dann hab ich den wieder nicht auf deutsch ;)

Doch du hast fast alles / außer dem Chrome (der die "Einstellungen/F2" übersetzt) in Deinem 1.5.4. Zumindest, wenn du es de-DE haben willst. ;)

Und wenn ich mir manch andere Software angucke. 1.6a ist so fehlerfrei, wie die ihren Kram an End-User ausliefern/probieren lassen. Denk mal an rapidshare.com grinning smiley



Edited 1 time(s). Last edit at 09/29/2010 05:11AM by guenter.

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: forever
Date: September 29, 2010 03:37PM

oh ok... die Einstellungen sind nicht so das Problem. Die können auch englisch sein.

Na denn werd ich mal testen ob alle meine Extensions funktionieren.
Danke für die Info

Options: ReplyQuote
Re: Problem with rapidshare.com in KM 1.5x
Posted by: guenter
Date: September 29, 2010 06:32PM

1.6 behandelt Chrome/XUL etwas anders. Deshalb sind die Probleme mit den Eintsellungen (desga2 hat ziemlich repariert) und ein paar Erweiterungen, die Xul nutzen. Sonst sollte alles funzen.

Verlege das jetzt mal nach General, weil kein K-Meleon spezifischer Bug.

mfG aus Hannover

Options: ReplyQuote


K-Meleon forum is powered by Phorum.