General :  K-Meleon Forum
General discussion about K-Meleon. 
Disable red underlining!?
Posted by: Ronery
Date: July 21, 2011 10:20PM

Hi all,
Whenever I type anything into a box I get red underlining, which I guess is spellchecking. I want it gone. How do I do it? Can't find the setting in Preferences.

thank you

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: siria
Date: July 21, 2011 11:48PM

Go to about:config, filter for "spell"
If not yet there, add this pref:

layout.spellcheckDefault
Integer
0

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: Ronery
Date: July 22, 2011 12:49AM

That did the trick, thank you! smiling smiley

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: Zero3K
Date: July 24, 2014 09:07AM

I'm still getting it in K-Meleon 74 Beta 4 even after changing the option as written.

EDIT: Nevermind, its just occurring on Google for some reason.



Edited 1 time(s). Last edit at 07/24/2014 09:17AM by Zero3K.

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: Mikk
Date: July 27, 2014 02:38PM

Mhmm, I have spelltest disabled in the K-Meleon Plugins and it underlines still anyway. Sometimes it goes very long until each word is underlined and this time I must wait, can do nothing others.sad smiley (KM 1.7)

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: rodocop
Date: July 27, 2014 07:37PM

in new KM74 spelltest isn't driven by spelltest kplugin but derives from the engine package.


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: K-Meleon-1.6db+NS // KM-16-S2014 // 1.6beta2.6 // K-Meleon Twin+

RECOMMENDED! K-Meleon 75.1 Pro: Download portable =//= Discuss on forum

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: Mikk
Date: July 28, 2014 03:42PM

In 1.7 allready too? I could believe it, the description for spelltest is (no information available) in the plugin settings. But how can I inactivate it?confused smiley

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: 4td8s
Date: August 06, 2014 06:43AM

Quote
Mikk
Mhmm, I have spelltest disabled in the K-Meleon Plugins and it underlines still anyway. Sometimes it goes very long until each word is underlined and this time I must wait, can do nothing others.sad smiley (KM 1.7)

weird. I don't have spelltest installed at all and I am using KM74 b4. I looked in K-meleon Plugins section and I dont see a spelltest plugin.



Edited 1 time(s). Last edit at 08/06/2014 06:44AM by 4td8s.

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: rodocop
Date: August 07, 2014 03:26AM

Quote
4td8s
weird. I don't have spelltest installed at all and I am using KM74 b4. I looked in K-meleon Plugins section and I dont see a spelltest plugin.

Nothing weird. KM74 has no any spelltest by itself but uses Gecko's one (built-in from engine).

And KM 1.7 depends on spelltest kplugin - so that case IS weird, yes.


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: K-Meleon-1.6db+NS // KM-16-S2014 // 1.6beta2.6 // K-Meleon Twin+

RECOMMENDED! K-Meleon 75.1 Pro: Download portable =//= Discuss on forum

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: Mikk
Date: August 07, 2014 03:08PM

As I startet the 1.7 first time I was asked if I want to install spell checking. I said NO. Neveertheles I got this underlining. Than sometimes - still getting red wave underelined textes - I found the check box for the spell checking in the plugin stettings, it was set off. Than later I changed all the file names considering the »spel« in any kind so that I set an underline sign in front of it, not to delete them yet. Than I was again asked if I want to install spell checking and I said again NO but that underlining was not disappeared. In following step I changed the extentions of that files from dll to dl. The check box in the plugin settings is away now but that underlinig - sometimes making even the readibilty of the text difficult - is still here.



Edited 1 time(s). Last edit at 08/07/2014 03:11PM by Mikk.

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: Mikk
Date: November 15, 2016 02:33PM

Sometimes, I don't know how and when, the red underlining disappeared and I forgot this problem almost completely. But abaout 2 weeks ago I lost my setteings and must make them anew, and together with it was the underlining back.

Now I found some hints here in the forum:
1. Somewhere I could read the suggestion, "layout.textarea.spellcheckDefault" to set to false. Found in kmeleon.js, done, but this alone didn't help.

2. http://kmeleonbrowser.org/forum/read.php?8,127127,127136#msg-127135
Quote
Zero3K
Quote
JohnHell
The problem is that happens without any spellchecker plugin LOL.

I was writting here and at the next moment, without doing anything... boom, underlinings everywhere.

Looks as if it was taking this thing from an unkown pref or something or maybe my es-ES dictionary or... who know, because even in the prefs, it is disabled... weird weird weird.

You can disable Spell Check completly by adding an integer named layout.spellcheck and give it a value of 0.
Than I searched by Windows all files containig "layout.spellcheck" in the KM folder and found

- xul.dll
- prefs-3.js
- kmeleon.js.

The 1st one is irrelevant for this, it checks this value, it's not possible to change here anything by smiple text editing without a large risk to destroy something. But in the others I did as recommended, set "layout.spellcheck" to value 0 and the underlining is now away.

I'm not sure if all these steps are necessary, perheaps only one of them but have no mind now to play with it on, it's secure not false if they all are set so. And it's documented and foundable with the forum search function here (search word "spell") for future purpose if somebody needs.

Also the suggestion from siria here above (21th July 2011 17:48), to do it via about:config, to set all values found under the term "spell" accordingly, shell lead to the destination. But it seems the editing of about:config doesn't work in the KM 1.7 alpha (if anybody knows a patch for it I'll be thankful for a message).



Edited 2 time(s). Last edit at 11/15/2016 02:56PM by Mikk.

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: siria
Date: November 15, 2016 05:25PM

1.7 ist just too much alpha, too many early bugs.
Yes, RIGHT-clicking in about:config shows the wrong menu there too.
Tip: DOUBLE-click on a pref.

Options: ReplyQuote
Re: Disable red underlining!?
Posted by: rodocop
Date: November 16, 2016 10:00AM

about:config in 1.7 is almost fully broken.

Use Preferential extension instead.


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: K-Meleon-1.6db+NS // KM-16-S2014 // 1.6beta2.6 // K-Meleon Twin+

RECOMMENDED! K-Meleon 75.1 Pro: Download portable =//= Discuss on forum

Options: ReplyQuote


K-Meleon forum is powered by Phorum.