General :  K-Meleon Forum
General discussion about K-Meleon. 
Pages: 123Next
Current Page: 1 of 3
Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Firebottle
Date: July 28, 2017 05:47PM

Anyone using Flash notice youtube videos... or any site that uses googlevideo streams... doesn't work anymore?

Just started this week... oddly, embedded videos from youtube still work for some reason.

In the past you can force flash to work by setting to false: media.webm.enabled, media.wave.enabled, media.ogg.enabled. Which disables HTML5 video.

I've tried everything, resetting prefs, changing user agent strings, etc.

Did google abandon flash after the announcement made this week by Adobe?

https://blogs.adobe.com/conversations/2017/07/adobe-flash-update.html

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: rodocop
Date: July 29, 2017 05:02AM

Flash-player is fully killed by youtube now.

The only option I can suggest is to use jojoplay videomirror site as described here


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: callahan
Date: July 29, 2017 02:38PM

I am not sure I understand about Youtube videos not playing. I am using (at present) KM 75.1 and the YT videos are still playing as always.

an example ... film "Tropic Zone" (1953) Google search

https://www.google.com/search?complete=0&site=webhp&q=tropic+zone+youtube&oq=tropic+zone+youtube&gs_l=psy-ab.12...41910.53309.0.55663.0.0.0.0.0.0.0.0..0.0....0...1.1.64.psy-ab..0.0.0.n-iviv2kXWc

Tropic Zone (1953)

https://www.youtube.com/watch?v=yhirsTaiIlE

I might not be understanding something correctly about YT videos no longer playing. Does that "Tropic Zone" film/video not play for others? It plays for me with 'JavaScript' not blocked in Tools/Privacy.


I also use Youtube Downloader HD to download and play and save YouTube videos. They play just fine after downloading and then I usually want to save some of them anyway. I use the portable version ... very stable, current version was released in February.

Youtube Downloader HD

http://www.youtubedownloaderhd.com/

Downloads:

http://www.youtubedownloaderhd.com/download.html

May not be what you really want but videos download nice and play very well with Media Player Classic in the full K-Lite Codec Pack 13.3.5.

http://www.free-codecs.com/download/k_l ... c_pack.htm

Added ... that Tropic Zone film also plays on KM 1.8.24.22 and K-Meleon 76 Pro.



Edited 1 time(s). Last edit at 07/29/2017 03:49PM by callahan.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Yogi
Date: July 29, 2017 04:02PM

Quote
callahan
I am not sure I understand about Youtube videos not playing.
I'm afraid you didn't.
Youtube doesn't serve flash content anymore but only HTML5.

The only issue I noticed with HTML5:
As long as the video is encoded with H.264 the quality is par (or could be even better) compared to flash.
If the video is encoded with VP8 or VP9 quality is lower.
Keep in mind that whatever codec is used the file extension is .MP4 (that's the container).

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: callahan
Date: July 29, 2017 05:48PM

Yogi ... OK, thanks ... I figured there was something I didn't fully understand with the Youtube videos. I mostly hunt YT videos with Google and watch them that way.

I hope that keeps working into the future.
...

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: 4td8s
Date: July 29, 2017 11:39PM

the built-in flashblock for KM does interfere with & prevent html5 based youtube videos from playing. I had to disable flashblock from the KM content filters section (adding the YT sites in the whitelist for flashblock doesn't work either) in order to actually watch html5 videos from Youtube.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Dee V
Date: August 05, 2017 05:52AM

I just tried to use YouTube with a fresh download of KM and got sent to a message page that said my browser is no longer supported. sad smiley

Is there something I can do to get KM to work on YouTube ?

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: smallhagrid
Date: August 05, 2017 06:27AM

Annoying, but not the end of all things.
Jojoplay does still allow viewing, so not all is offline now.
(It also opens malware-ish pop-ups though, which drives NOD32 on my PC nuts !!)

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Dee V
Date: August 05, 2017 07:45AM

Quote
smallhagrid
Annoying, but not the end of all things.
Jojoplay does still allow viewing, so not all is offline now.
(It also opens malware-ish pop-ups though, which drives NOD32 on my PC nuts !!)

Not sure why, but KM is working(ish) on Youtube now. But won't display some videos.

when I check KM on youtube.com/html5 it gives me red exclamation for :
-MSE & WebM VP9,
-Media Source Extensions,
-H.264,
-MSE & H.264

Can KM play HTML5 videos at all ?

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Dee V
Date: August 05, 2017 10:05AM

Quote
Dee V
Quote
smallhagrid
Annoying, but not the end of all things.
Jojoplay does still allow viewing, so not all is offline now.
(It also opens malware-ish pop-ups though, which drives NOD32 on my PC nuts !!)

Not sure why, but KM is working(ish) on Youtube now. But won't display some videos.

when I check KM on youtube.com/html5 it gives me red exclamation for :
-MSE & WebM VP9,
-Media Source Extensions,
-H.264,
-MSE & H.264

Can KM play HTML5 videos at all ?

The chromium based browser plays all video formats on YouTube and also works with my old xp system and old cpu which doesn't have sse2

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Dee V
Date: August 05, 2017 10:06AM

Quote
Dee V
Quote
Dee V
Quote
smallhagrid
Annoying, but not the end of all things.
Jojoplay does still allow viewing, so not all is offline now.
(It also opens malware-ish pop-ups though, which drives NOD32 on my PC nuts !!)

Not sure why, but KM is working(ish) on Youtube now. But won't display some videos.

when I check KM on youtube.com/html5 it gives me red exclamation for :
-MSE & WebM VP9,
-Media Source Extensions,
-H.264,
-MSE & H.264

Can KM play HTML5 videos at all ?

The chromium based browser plays all video formats on YouTube and also works with my old xp system and old cpu which doesn't have sse2

oops. The browser is called "The World"

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: siria
Date: August 05, 2017 11:46AM

Do direct links still work for you?
Without "embed" or "watch" in the adress, e.g.
https://www.youtube.com/v/tvyjZIDuzEM

Still works on my ancient KM1.6 and OS, and is also the only chance since a few years. Always thought such links show flash, but now not so sure anymore, could also be mp4. Right-clicking still shows the flash-context menu. And not quite sure if it's even played by the browser itself, or perhaps just the additional VLC-plugin. But that youtube-html5 test page says KM1.6 can play "html-video element"

So technically, youtube videos still work that way on old KMs and machines, except if blocked intentionally by yt. Which gets a bit nasty if they refuse to play with an error message "only allowed to watch on yt directly" (or such, and yes, referers+cookies+JS etc allowed)
https://www.youtube.com/v/MePaWG7g5FA
No workaround for that yet sad smiley

Recently had the prob that not even this only last chance worked anymore.
First thought the culprit was this pref "plugin.load_flash_only", but after toggling it back things still seemed to work, so no idea.

Sometimes I also download videos on clipconverter.cc, works very nicely without unnecessary frills.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Yogi
Date: August 05, 2017 01:58PM

@Dee V

If I check KM76RC2 on youtube.com/html5 it tells me that all media types are supported.
See screenshot.

I see now that you are on WinXP. Since WinXP has no native support for H.264, you'll have to google for a solution. I can't help since I'm on Win7.
All other media types should work for WinXP by default.

My settings in "about:config"
media.mediasource.enabled;true (= default setting)
media.mediasource.mp4.enabled;true (= default setting)
media.mediasource.webm.enabled;true (default setting = false)

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Yogi
Date: August 05, 2017 02:38PM

Quote
siria

https://www.youtube.com/v/tvyjZIDuzEM

Always thought such links show flash, but now not so sure anymore,

It's flash. Plays fine with KM76RC2 on Win7.


Quote
siria

https://www.youtube.com/v/MePaWG7g5FA
No workaround for that yet sad smiley

This one would play also fine (for me at least) if the content weren't restricted.
However YT offers another link (webm instead of flash) where you can watch the clip: https://www.youtube.com/watch?v=MePaWG7g5FA&feature=player_embedded



Edited 1 time(s). Last edit at 08/05/2017 02:39PM by Yogi.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: siria
Date: August 06, 2017 02:18AM

Interesting, thanks.

Those standard "/watch" views are exactly what I can't get to work anymore. Only in FF10, but that freezes on most pages after a few seconds, just too little RAM. On yt first shows a few seconds video+sound, then video freeze plus but a few more seconds sound, then whole FF frozen.

PS have read the "webm" prefs are hardware dependant, only work with INTEL.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Dee V
Date: August 06, 2017 04:47AM

thanks siria and yogi.

Your workarounds are interesting but this link is the test criteria for me:
youtube.com/html5

My old hardware and operating system gets all blue check marks with "TheWorld" browser so for now I will rely on it.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: guenter
Date: August 06, 2017 02:12PM

The problem is that under XP the engine used by FF and KM cannot work for some media types.

So it does not work like on Vista or Win 7.

It is by design since Mozilla wanted to evade the licence fees for the codecs.


You have to use a chrome version for XP to play these media types.

I use the XP capable version from here:

http://browser.taokaizen.com/

ALPHABET Inc. / Google gave rights to the codecs to Chromium.


IE? Wasn't that the program that downloaded my first real browser?



Edited 2 time(s). Last edit at 08/06/2017 02:57PM by guenter.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Yogi
Date: August 06, 2017 04:52PM

Quote
guenter
The problem is that under XP the engine used by FF and KM cannot work for some media types.

So it does not work like on Vista or Win 7.

It is by design since Mozilla wanted to evade the licence fees for the codecs.

Mozilla is open source.
H.264 is proprietary.
Both Google and Microsoft are co-owners. No other browser vendor can afford to implement into its browser, code to render this proprietary format.
So the only browsers with support for H.264 rendering on an OS that doesn't have native implementation therefore are those of Google and Microsoft and browser shells using their code. Such a browser is e.g. The World Browser (using the Trident Chromium engine).
There are workarounds for Linux (ffmpeg) and AFAIK there are some for WinXP as well. However I had no XP, neither in the past nor now, so I never bothered for details.



Edited 1 time(s). Last edit at 08/13/2017 09:03PM by Yogi.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: J.G.
Date: August 08, 2017 01:11AM

I think this is not a problem of Kmeleon but the O.S. itself. No problem for me visiting sites from the very beginning w/ Windows 10, all old plugins installed and KMeleon 76RCPro by Rodocop. Simply loving it! smiling smiley

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: foliator
Date: August 10, 2017 03:20AM

Quote
Yogi
My settings in "about:config"
media.mediasource.enabled;true (= default setting)
media.mediasource.mp4.enabled;true (= default setting)
media.mediasource.webm.enabled;true (default setting = false)

If I set media.mediasource.enabled to true, all the formats are checked as enabled on youtube.com/html5. If I disable it, of course, YouTube shows checkmarks in the top three items, but the bottom three relating to media source extensions are unchecked. YT videos play fine whether that setting is enabled or disabled.

However, I generally leave it disabled, because it makes a big difference on non-YouTube MP4 videos, such as this one:

https://www.theguardian.com/culture/video/2016/apr/25/patrick-stewart-sketch-what-has-the-echr-ever-done-for-us-video

This is very choppy with the setting enabled, and smooth with it disabled. I suppose this means that MSE is not implemented in KM 75.0. On the other hand, MSE is implemented in recent versions of Pale Moon, and all the videos are choppy there, including Flash and HTML5. With MSE disabled in PM, some videos won't even play.

-----

Using KM 75.0 on Windows 7 (x86)

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: foliator
Date: August 10, 2017 04:15AM

Quote
Dee V
The chromium based browser plays all video formats on YouTube and also works with my old xp system and old cpu which doesn't have sse2

oops. The browser is called "The World"

@Dee V: Which version of The World are you using? Version 7 recently stopped playing YouTube videos on my Windows 7 machine, although it plays other videos very well.

-----

Using KM 75.0 on Windows 7 (x86)

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Dee V
Date: August 10, 2017 08:02AM

Quote
foliator
Quote
Dee V
The chromium based browser plays all video formats on YouTube and also works with my old xp system and old cpu which doesn't have sse2

oops. The browser is called "The World"

@Dee V: Which version of The World are you using? Version 7 recently stopped playing YouTube videos on my Windows 7 machine, although it plays other videos very well.

I use Version 6.2.0.128

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: foliator
Date: August 10, 2017 09:03AM

Quote
Dee V
Quote
foliator
Quote
Dee V
The chromium based browser plays all video formats on YouTube and also works with my old xp system and old cpu which doesn't have sse2

oops. The browser is called "The World"

@Dee V: Which version of The World are you using? Version 7 recently stopped playing YouTube videos on my Windows 7 machine, although it plays other videos very well.

I use Version 6.2.0.128

Thanks. I tried that in the past, but liked Version 7 better, especially because it automatically downloaded a portable version of Pepper Flash. I need Flash for many streaming sites other than YouTube that still rely on it. The Pepper Flash DLL file, which I've kept, is now working fine with another Chromium-based browser (SRWare Iron). That's my alternate browser.

-----

Using KM 75.0 on Windows 7 (x86)



Edited 1 time(s). Last edit at 08/10/2017 09:03AM by foliator.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: J.G.
Date: August 10, 2017 06:15PM

I always read these latest workarounds to get a better browsing, although I have never noticed such an ungly problem that doesn't allow me to browse fluently and fine. Probably I'm the luckiest websurfer in the world or something unknown for me. mad smiley Or probably I have a very light surfing behaviour. However, I hope that Rodocop is collecting all these new workarounds to valuate if they should be merged for future releases of KM 76RC-pro-portable, because as further as I know it's the only branch that is currently open for development. Sorry about that. confused smiley

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: Yogi
Date: August 10, 2017 10:39PM

Quote
foliator

If I set media.mediasource.enabled to true, all the formats are checked as enabled on youtube.com/html5. If I disable it, of course, YouTube shows checkmarks in the top three items, but the bottom three relating to media source extensions are unchecked. YT videos play fine whether that setting is enabled or disabled.

However, I generally leave it disabled, because it makes a big difference on non-YouTube MP4 videos, such as this one:

https://www.theguardian.com/culture/video/2016/apr/25/patrick-stewart-sketch-what-has-the-echr-ever-done-for-us-video

This is very choppy with the setting enabled, and smooth with it disabled.

I'm afraid that it is a matter of hardware. The above vid plays smoothly here.

Quote
foliator
I suppose this means that MSE is not implemented in KM 75.0.

KM has everything implemented what Mozilla's Gecko engine on which it is based, has. Keep in mind that KM 75 is based on Firefox ESR 31. Actual Firefox ESR is 52.3.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: foliator
Date: August 11, 2017 01:40AM

Quote
Yogi
KM has everything implemented what Mozilla's Gecko engine on which it is based, has. Keep in mind that KM 75 is based on Firefox ESR 31. Actual Firefox ESR is 52.3.

Yes, I realize that. This is why I keep an alternate browser on hand. KM 76rc has problems on my machine. KM 76 Pro fixes a few of them, but I've customized my current version very heavily, especially the toolbars (including custom icons) and menus. In 76 Pro I found I'd have to go through a lot of that again. Besides, Gecko 38 still doesn't support a few of my favorite websites.

As it stands now, I use KM 75.0 for web searches and reading the text content on websites, but switch to Iron if I want to view videos or streaming webcams, or if a site uses scripts that K-Meleon can't handle (this is starting to happen more often).

As for the latest Firefox release, forget it! tongue sticking out smiley

-----

Using KM 75.0 on Windows 7 (x86)

Options: ReplyQuote
Re: Flash, youtube, xp... / custom skin
Posted by: siria
Date: August 11, 2017 03:12AM

Quote
foliator
KM 76 Pro fixes a few of them, but I've customized my current version very heavily, especially the toolbars (including custom icons) and menus. In 76 Pro I found I'd have to go through a lot of that again.

Would just try to copy over your customized files, as they are. Can make things easier for the future too. Worth a try?
For example, in the "skins" folder, users can create an own subfolder with a free name (myskin or whatever). Copy into it the files that you've customized, especially toolbars.cfg and the new icons. Perhaps also skin.cfg, skin.js, menuicons.cfg if changed, but that depends, would just look and try what works best.
Choose that "new skin" in F2>GUI and restart the browser.
Whatever skin elements and icons may now be missing, KM will automatically look up in various places, first in the profile folder, then in "skins/default" and "skins/shared" folders.

Probs may occur at first if "default" icons are differently named in the two KM versions, in that case just copy those over too.
It also doesn't harm to copy over the complete old "default" folder into the brandnew own skin folder. Just don't overwrite things in the original "default" folder.

Options: ReplyQuote
Re: Flash, youtube, xp... / custom skin
Posted by: foliator
Date: August 11, 2017 05:51AM

@siria: Well, this time I prefer to take the lazy way out and use an alternate browser for sites that don't work in KM.

Another thing I've tried is a macro that opens the current URL in my alternate browser. I use a very long and complicated command line with Iron, not just the executable file. Those parameters are essential, however, so I wrote a batch file to start it with those parameters, then created a very small KM macro that simply runs that batch file. Edit: I've now defined the entire command line as the program variable within the quotation marks in the macro, so I can toss out that batch file. Works even better!

I ran into yet another of my favorite streaming webcams this morning that no longer plays in KM. The site underwent some changes overnight. It still uses Flash, as I found out by temporarily renaming the Flash .dll file with a .bak extension (I don't use Flash Block). That brought up a no-flash error message from the site, which also stated that it doesn't have HTML5 media support. Apparently KM can't deal with the site's new scripts, although they work in Iron.

Occasionally I run into problems calling those external apps from KM. I have a small utility that toggles my WiFi on and off, and can call it from a KM macro. It appears to work, but for some reason it has no effect on the WiFi. If it's enabled at the time and I select disable in the app, the WiFi just stays enabled, and vice-versa. If I run the utility from outside of KM, e.g. from the start menu or a hotkey, it works fine, even if KM is running at the time.

-----

Using KM 75.0 on Windows 7 (x86)



Edited 3 time(s). Last edit at 08/11/2017 07:55AM by foliator.

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: J.G.
Date: August 11, 2017 07:51AM

Quote
siria
https://www.youtube.com/v/MePaWG7g5FA
No workaround for that yet sad smiley

This video has restricted content from SME (Sony Music Entertainment). sad smiley By the way I'm testing now the DuckDuckGo spider with good results on Youtube and long websites filled with any kind of content. As I said, I have never noticed such an ungly problem that doesn't allow me to browse fluently and fine with 76RCpro, but I like to experiment some new UA to see the differences showing the pages. smiling smiley

DuckDuckBot/1.0; (+http://duckduckgo.com/duckduckbot.html)

Options: ReplyQuote
Re: Flash, youtube, xp and mozilla/k-meleon browsers no longer working
Posted by: guenter
Date: August 11, 2017 06:52PM

There seems to be a workaround to surpass the OS XP owed limits of recent Mozilla browsers.

Enable MP4 (H.264 + AAC) HTML5 video


I got stuck however with FF ESR 52 saying that the Primetime Content Decryption Module "will be installed shortly".

p.s. I had hoped to get that going and look into K-Meleon using it.

p.p.s. Used wrong type "integer" instead of "string" for "media.gmp-eme-adobe.version". I have it working for FF now. But still not showing in plugins list with K-Meleon. Maybe intentionally excluded by Mozilla devs. https://bugzilla.mozilla.org/show_bug.cgi?id=1288582#c3


IE? Wasn't that the program that downloaded my first real browser?



Edited 2 time(s). Last edit at 08/12/2017 01:48AM by guenter.

Options: ReplyQuote
Pages: 123Next
Current Page: 1 of 3


K-Meleon forum is powered by Phorum.