Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
A problem with Aero. In Windows Vista
Posted by: catc
Date: August 11, 2016 09:00PM

I have a problem when I use K-Meleon with Aero. Pages sometimes do not display. And the page is just black instead. Or there are problems where artefacts of some of the last few pages that I visited are still there. And these problems do not happen with the Windows standard theme.
The version of K-Meleon is 75.1.


http://photos.google.com/share/AF1QipOzqtj-VALbADDwGUVhMsVZe241eZFmWk2yTJJJzXoJxfPs3mOm1QRafabO66Cfng?key=TzdEYk4wMVFxRkFoVDFadjVQN1Vra0NvRWxDYXRR



Edited 1 time(s). Last edit at 08/12/2016 04:57AM by catc.

Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: 4td8s
Date: August 21, 2016 10:22AM

what edition of Windows Vista are you using (and is it at SP2 level)?

Vista home basic & starter editions do not have aero.

could be a problem with your video card or graphics drivers perhaps.

Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: catc
Date: August 23, 2016 10:19PM

I am using Windows Vista Ultimate x64. And it is at SP2 level.
And my video cards are working fine. And the drivers are fine as well. It happens on both of my PCs running Windows Vista Ultimate. One of the PCs has a Palit GTX 460. And the other has a HIS IceQ X HD 6770.
And I do not have this problem in other programs when running Aero. Including other web browsers.



Edited 1 time(s). Last edit at 08/23/2016 10:20PM by catc.

Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: siria
Date: August 24, 2016 04:10AM

The newer KM version seem quite often to have some "black problem", and Dorian couldn't fix it a long time but thought it was meanwhile. Which KM version have you tried? Also the latest KM76RC2?
An older tip, seems to help sometimes:
http://kmeleonbrowser.org/forum/read.php?8,138447,138595#msg-138595

Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: catc
Date: August 29, 2016 10:01PM

I have tried version 75.1. And also 76RC2. And they both have the problem.
And I tried setting layers.offmainthreadcomposition.enabled to false. And it did not fix the problem.

Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: JohnHell
Date: August 29, 2016 10:53PM

Open this and toogle to true:

about:config?filter=layers.acceleration.disabled


I think I'll end using this as a signature XD





Edited 1 time(s). Last edit at 08/29/2016 10:53PM by JohnHell.

Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: catc
Date: August 31, 2016 10:55AM

Quote
JohnHell
Open this and toogle to true:

about:config?filter=layers.acceleration.disabled

I tried that. And it has worked! The problem has gone. Thank you for your help.
smiling smiley



Edited 1 time(s). Last edit at 08/31/2016 11:12AM by catc.

Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: JohnHell
Date: August 31, 2016 11:25PM

Just my own curiosity, so no needed to post anything if you don't want to.

What does K-meleon tell to you your adapter is under "Graphics" after type in the url bar about:support?



Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: catc
Date: September 04, 2016 11:53AM

Quote
JohnHell
Just my own curiosity, so no needed to post anything if you don't want to.

What does K-meleon tell to you your adapter is under "Graphics" after type in the url bar about: support?

It tells me that my graphics adapter is a Geforce GTX 460:



Adapter Description NVIDIA GeForce GTX 460
Adapter Drivers nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM 1024
Device ID 0x0e22
Direct2D Enabled true
DirectWrite Enabled true (7.0.6002.23771)
Driver Date 6-17-2015
Driver Version 10.18.13.5330
GPU #2 Active false
GPU Accelerated Windows 0/1 Basic
Vendor ID 0x10de
WebGL Renderer Google Inc. -- ANGLE (NVIDIA GeForce GTX 460 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote false
AzureCanvasBackend direct2d
AzureContentBackend direct2d
AzureFallbackCanvasBackend cairo
AzureSkiaAccelerated 0



Edited 1 time(s). Last edit at 09/04/2016 11:54AM by catc.

Options: ReplyQuote
Re: A problem with Aero. In Windows Vista
Posted by: JohnHell
Date: September 05, 2016 10:40PM

High end and quite updated drivers and still happen :-?

Very interesting.

Trying to make browsers like a content player looks like it wasn't a good idea.



Options: ReplyQuote


K-Meleon forum is powered by Phorum.