Announcements :  K-Meleon Forum
 
Pages: Previous123456
Current Page: 6 of 6
Re: K-Meleon 74.0 Release
Posted by: siria
Date: November 01, 2014 03:12AM

Whish we could rename KM74gre31 into KM75beta1 cool smiley

Options: ReplyQuote
Re: K-Meleon 74.0 Release
Posted by: Luys
Date: November 01, 2014 09:50PM

Muchas gracias por tu rĂ¡pida respuesta, JohnHell, ahora ya lo tengo claro.
Saludos.
Luys.
---
Thank you very much for your quick response, JohnHell, now I know what the differences are.
Greetings.
Luys.

Options: ReplyQuote
Re: K-Meleon 74.0 Release
Posted by: Zero3K
Date: November 01, 2014 11:54PM

Dorian: Please take a look at http://kmeleon.sourceforge.net/flyspray/index.php?do=details&task_id=3 and try to fix it. Thanks in advance.

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: Victor
Date: November 07, 2014 05:28AM

Thanks you very much for new version, this a great software smiling smiley

Thanks you for your contribution.

Greetings

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: torbetron
Date: November 09, 2014 01:31PM

Greetings,

I had been using version 74 beta 3, and just now decided to download this version, as it seems to be an official release. With the beta 3 I was having a problem with bookmarks, and with Guenter's help I fixed it temporarily. Please see my post at:
http://kmeleon.sourceforge.net/forum/read.php?8,127127,127713#msg-127713

Anyway, I'm now seeing this same problem where when I save a bookmark, it saves only the name of the site and not the URL. Guenter's temporary fix for beta 3 was to move the msv*80.dll files from release 1.6 into the main K-meleon directory. I tried that again with this official release version, but unfortunately it didn't fix the problem this time.

Is anyone else having the problem that URL is not being saved with bookmark? I'm using Windows XP, SP3.

Thank-you for your help, and I hope this is the right thread to be asking this question.

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: siria
Date: November 09, 2014 02:01PM

Seems a serious bug yet in KM74.0, here too:
http://kmeleon.sourceforge.net/forum/read.php?3,128382

Now you only mention the msv-dlls, but your own link said to copy over the bookmarks.dll from 1.6 into kplugins (the msv-dlls are only helper files for this old bookmarks.dll, probably only necessary if not already in some global windows folder somewhere)

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: guenter
Date: November 09, 2014 02:51PM

Quote
torbetron
I tried that again with this official release version, but unfortunately it didn't fix the problem this time.

You only did part off what You did for 74.b3. The workaround uses the bookmarks.dll from 1.6 or 1.7 and that file needs the msv*80.dll as helper file(s).

Anyway AFAIR there is a problem when an empty bookmarks file is used, no bookmarks.html or a write prtected bookmarks exists. IMHO Dorian must have
read that report.

Untill version 1.6/1.7 K-Meleon bookmarks plugin issued a warning and started a new bookmarks.html. Now no warning and problems.

No siria, it is IMHO no serious bug.

How often do You have no or a write protected bookmarks.html?

Every once in a blue moon.



Edited 1 time(s). Last edit at 11/09/2014 05:13PM by guenter.

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: siria
Date: November 09, 2014 04:19PM

guenter, you keep telling that the whole bookmarks.html wouldn't get stored, didn't exist at all or were write-protected.

But at least 3 users have now said that their new TITLES of the bookmarks do get saved, just not the URL. That sounds to me that their bookmarks.html IS changed and stored, only incomplete.

Perhaps 2 different bugs? There should be more testers.

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: guenter
Date: November 09, 2014 05:41PM

Quote
siria
guenter, you keep telling that the whole bookmarks.html wouldn't get stored, didn't exist at all or were write-protected.

But at least 3 users have now said that their new TITLES of the bookmarks do get saved, just not the URL. That sounds to me that their bookmarks.html IS changed and stored, only incomplete.

Perhaps 2 different bugs? There should be more testers.

I keep telling what tests I did to reproduce the alleged bugg.

XP SP3 / It might be system specific like that I have no spellckeck.

I deleted bookmarks.html and I later write protected it intentionally. Then in both I tried to bookmark. The next new bookmark does not get stored on my machine. No real alarm, no new file is started.

We probably could skip write protect as no fix possible.

But a somehow lost bookmarks.html (e.g. after a skandisk run) must

a.) raise a warning that no bookmarks.html was found

b.) start a new bookmarks.html to store the next bookmark.

Why a.) The user may want to investigate where the old html is. Locate it or use a backup. Users rarely delete this file.

Why b.) If the user deleted it intentionally a new one must be started automtically.

In both cases (which rarely happen in real live) the plugin makes problems.

And it is easy enough to test on Your Vista machine for Vista. It would IMHO
save Dorian's time, if we had a test or two for each Windows, so he does not have to start a virtual machine with it. It probably does not cause problems on his machine's OS.

No I think it is the same bug or a related problem.

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: torbetron
Date: November 09, 2014 10:11PM

Thank-you for your quick response on this. Yes, you're right I forgot to move the version 1.6 bookmarks.dll file into kplugins folder. Once I did that then bookmarks function properly (URL is saved along with title of page).

I will note that when I completely uninstall K-Meleon from my machine, including preferences/profile, then re-install this newest version 74 release, then I experience this bug of URL not being saved in a new bookmark. This happens when I have no existing bookmarks.html, and it just opens the default basically empty one in K-Meleon subdirectory Profiles/s04fykym.default.
But also, when I copy my existing bookmarks.html into this subdirectory, I also experience the bug. So, it doesn't seem to be related to whether the bookmarks.html file exists or not beforehand.

Is this bug only found on Windows XP SP-3 machines? Will this have to be something I need to do every time I download a new version of K-Meleon?

Thank-you for your kind assistance.
-Eric

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: guenter
Date: November 10, 2014 12:37AM

I am glad You found out why. Yes. It can be only for us XP users. We two will see when more tests results from newer versions are posted.smiling smiley

IMHO. Do not uninstall completely.*.) New versions can use older profiles. With some help from us they can use them way back to the 1.5 and earlier versions. Dorian knitts them that way. & he does not invent a new wheel for each version.
I hope.smiling smiley

p.s. *.) I always install as portable. And I start a new version in the default way once. I look for some old bugs... After that I prepare the new km for my normal uses. I copy my favorite skin, skins/default/... and favorite user defined macros over. And then I copy all of the most recent profile into the once test & used brand new profile. That gives me my settings, bookmarks, hotlist, passwords and my Firefox add-ons in ./used_profile/extensions and macros. That is all I want. cool smiley

And I experience no bug if I copy bookmarks.html to a new place for use.
Please check whether it is protected ... at Your PC...

Greetings to the west coast from far east Germany.



Edited 1 time(s). Last edit at 11/10/2014 12:53AM by guenter.

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: Dorian
Date: November 10, 2014 06:11AM

I can see that the spanish locale of bookmarks is bugged because of something I said (and corrected after). So the spanish locale has this bug for sure.



Edited 1 time(s). Last edit at 11/10/2014 06:14AM by Dorian.

Options: ReplyQuote
Re: K-Meleon 74 Release
Posted by: gordon451
Date: November 10, 2014 11:20AM

Hi Dorian -

Not sure if this is the best place, but...

I've uncovered a couple of bugs, posted in the "Bugs" forum and put up on Flyspray. FS#2 is really serious, as I can't work on FS#7 until it's fixed.

However, with 74-31 on its way, maybe FS#2 doesn't matter? smiling smiley

BUt I can't hold my breath for very long sad smiley

Gordon.

____________________
Gigabyte H61M-USB3-B3 r2.0, I5-2400 3.10GHz, 4GB RAM; W7HPx64 SP1, Lotus SmartSuite 9.8, K-Meleon 75, Opera 12.17x64, IE11, Clyton email 13.0, Foxit Reader 7.0.6.1126, PaintShop Pro 6.02, Avast! 12.3.2280, SuRun 1.2.1.2, VoodooShield 3.51

__________________
Television is the first truly democratic culture -- the first culture available to everyone and entirely governed by what the people want. The most terrifying thing is what people do want. [Clive Barnes, 1969]



Edited 1 time(s). Last edit at 11/10/2014 11:20AM by gordon451.

Options: ReplyQuote
Re: K-Meleon 74 Release not works in w9k nor w2k
Posted by: gordon451
Date: November 10, 2014 11:37AM

Quote
guenter
Quote
Nitrolobo
Thank you for your effortts, but both Beta 164 (even portable) neither version 74 works in Windows 98 and Windows 2000, even loading in them vcredist.exe and the dll. you say (Windows 2000 Pro Pack 4 just includes it.)

This is upsetting, since many of us still use to run old wonderful harware P 2 and P 3, and K-Meleon 1.5 had been as a useful tool, now outdated.

...He put me on the spoor to a German Win 2000 update past SP 4. The server version of Win 2000 got MS updates longer.

OK, it's a month old, sorry I never spotted it before.

1.6x and older would run natively on W2K SP4 Rollup 1. Youse must have the Rollup 1. Be careful and keep an eye on it, because it would get pushed out of the way by some other installs/upgrades, and needs to be reinstalled. W2K SP4 Rollup 1 was the best ever of MS' offerings, but it did have a couple of annoyances... surprised smiley

And it helps to put in VC2008, '09 and '10 as well, they are really simple to install, not like in XP++ grinning smiley.

Gordon.

____________________
Gigabyte H61M-USB3-B3 r2.0, I5-2400 3.10GHz, 4GB RAM; W7HPx64 SP1, Lotus SmartSuite 9.8, K-Meleon 75, Opera 12.17x64, IE11, Clyton email 13.0, Foxit Reader 7.0.6.1126, PaintShop Pro 6.02, Avast! 12.3.2280, SuRun 1.2.1.2, VoodooShield 3.51

__________________
Television is the first truly democratic culture -- the first culture available to everyone and entirely governed by what the people want. The most terrifying thing is what people do want. [Clive Barnes, 1969]

Options: ReplyQuote
Re: K-Meleon 74 Release not works in w9k nor w2k
Posted by: JohnHell
Date: November 10, 2014 09:03PM

1.6 works without any magic, except for flash requirements.

I don't have installed the Rollup (shit by MS), but what K-meleon 74 needs are kernel extenders, not the latest Rollup Hotfix, believe me.

You maybe have installed the kernel extenders, sometimes called rollup by guys like BlackWingCat, but his releases aren't the actual Rollup by Microsoft.

I'll go beyond, VC++10 can't be installed on Windows 2000 unless modified installers. You need to place the files manually.



Edited 6 time(s). Last edit at 11/10/2014 09:15PM by JohnHell.

Options: ReplyQuote
Re: K-Meleon 74 Release not works in w9k nor w2k
Posted by: guenter
Date: November 11, 2014 02:08AM

Quote
gordon451

And it helps to put in VC2008, '09 and '10 as well, they are really simple to install,

Maybe VC 8 and VC 9 but not VC 10 build apps.

For 2000 You'd need updates past the last update by MS just like JohnHell wrote.

BlackWingCat's, OldCigarettes, ... updates/Extenders are not awailable in German.



Edited 1 time(s). Last edit at 11/11/2014 02:09AM by guenter.

Options: ReplyQuote
Re: K-Meleon 74 Release not works in w9k nor w2k
Posted by: gordon451
Date: November 11, 2014 06:42AM

Quote
guenter

Maybe VC 8 and VC 9 but not VC 10 build apps.

For 2000 You'd need updates past the last update by MS just like JohnHell wrote.

I never actually "installed" any of those. Just find the relevant msvcrxxx.dll and (IIRC!) msvcpxxx.dll, then drop them into the .\windows folder, was it the \System32? confused smiley Over 2 years ago... The box developed Alzheimer's in 2012, the CPU I think, and I couldn't find a new one with W2K drivers, so...

But no actual "install". I was never interested in building apps, just running them. And I did have a drama when Rollup 1 got over-written with one app install, and a whole heap of other apps crashed! I was running a lot of apps which said they needed XP/Vista, and getting better mileage out of them!

I see where JohnHell is coming from. I don't think Km74 would have run on W2K at any stage no matter what VC updates you dropped in. Definitely a Kernel Extender would be needed.

Gordon.

____________________
Gigabyte H61M-USB3-B3 r2.0, I5-2400 3.10GHz, 4GB RAM; W7HPx64 SP1, Lotus SmartSuite 9.8, K-Meleon 75, Opera 12.17x64, IE11, Clyton email 13.0, Foxit Reader 7.0.6.1126, PaintShop Pro 6.02, Avast! 12.3.2280, SuRun 1.2.1.2, VoodooShield 3.51

__________________
Television is the first truly democratic culture -- the first culture available to everyone and entirely governed by what the people want. The most terrifying thing is what people do want. [Clive Barnes, 1969]

Options: ReplyQuote
Pages: Previous123456
Current Page: 6 of 6


K-Meleon forum is powered by Phorum.