Announcements :  K-Meleon Forum
 
Pages: Previous1234Next
Current Page: 3 of 4
Re: K-Meleon 75.1 Beta
Posted by: JohnHell
Date: August 08, 2015 04:57AM

Quote
Dorian
Is there still anything having transparency on w2K ? confused smiley (bookmark toolbars, ...)

Sure!, toolbars. The last frontier of backgrounds in 75.1 (let me joke with this).

Quote
Dorian
Klassic skin look fine on xp (not seeing problem with magenta here)

You are right but is happening with only one image, that never happened before on XP nor on 2K, in my skin. Curious. Weird. I'll send it.



You'll see that the skin it was based on was Netscape Modern 0.8 (I've seen the readme while cleaning it). I can't see it in the skins section of the web :S

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: siria
Date: August 08, 2015 05:30AM

Quote
Dorian
Quote
JohnHell
The bug in the url bar loading the content as url, if I'm not wrong, can be reproduced as:

It happens when the content of the url bar and the first choice in the drop down list are the same. This is probably not new, and the default behavior of the combo box. Not sure how I can fix this.

Actually - yes! surprised smiley Happens in KM1.6 too, and never noticed it either!
Probably because I rather type the URL beginning first, then choose from the automatic dropdown, because otherwise KM1.6 on win98 has (another) bad bug with urlbar arrow too.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: JamesD
Date: August 08, 2015 07:02PM

Update edit: If should not be capitalized. I fixed that and now am testing more. All menus show.


I have questions about functions being defined in macros.

Is an "if (condition) statement allowed in a function?

Does the code in a function run prior to being called? By this I mean at KM startup.

I am getting an error message about a function 'if' in the following code.
The alert for 'broken' is displayed at KM startup. Many menu items including the Error Console are not shown with my new macro in place.

function _urlbarcolorcompute( $_urlbarcolor_red, $_urlbarcolor_blue, $_urlbarcolor_green, $_urlbarcolor_input) {
  $_BlueValue = $_urlbarcolor_blue*65536; $_GreenValue = $_urlbarcolor_green*256;
  If ($_urlbarcolor_input == "secure") {
    setpref( INT, "browser.urlbar.highlight.secure",   $_BlueValue+$_GreenValue+$_urlbarcolor_red);
    $_urlbarcolor_report = getpref(INT,"browser.urlbar.highlight.secure");
    alert("has the integer value of ". $_urlbarcolor_report, "browser.urlbar.highlight.secure");    
    } else {
    setpref( INT, "browser.urlbar.highlight.broken",   $_BlueValue+$_GreenValue+$_urlbarcolor_red);
    $_urlbarcolor_report = getpref(INT,"browser.urlbar.highlight.broken");
    alert("has the integer value of ". $_urlbarcolor_report, "browser.urlbar.highlight.broken"); 
  }
}

The function is called from this line of code.
$_urlbarcolor_ask == "YES" ?  _urlbarcolorcompute( $_urlbarcolor_red, $_urlbarcolor_blue, $_urlbarcolor_green, $_urlbarcolor_input)  : macros("_urlbarcolor_retrycancel");



Edited 2 time(s). Last edit at 08/09/2015 01:02AM by JamesD.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: JamesD
Date: August 09, 2015 09:51PM

After I got past my 'senior moment' if putting a capital I in an 'if' statement, I made good progress on the macro.

urlbarcolor.kmm will
allow user to compute and set the long color value for either the "browser.urlbar.highlight.secure" or "browser.urlbar.highlight.broken" pref. Requires that the user provide the RGB or Red, Green, and Blue values as decimal numbers and either 'broken' or 'secure to select which pref's value is being set.

https://dl.dropboxusercontent.com/u/1522294/urlbarcolor.7z

The macro also contains a function definition and call.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Dorian
Date: August 10, 2015 03:50AM

We're off topic but can't resist to simplify the function.
You don't need to prefix the function parameters, they can only be seen by the function.

function _urlbarcolorcompute( $red, $blue, $green, $input) {
  if ($input != "secure") $input = "broken";
  $urlbarcolor_pref = "browser.urlbar.highlight.".$input;
  $urlbarcolor_color = $blue*65536 + $green*256 + $red;  
  setpref(INT, $urlbarcolor_pref, $urlbarcolor_color);  
  $_urlbarcolor_report = getpref(INT,$urlbar_pref);
  alert("has the integer value of ". $_urlbarcolor_report, $urlbar_pref);
}



Edited 1 time(s). Last edit at 08/10/2015 03:50AM by Dorian.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Dorian
Date: August 10, 2015 04:02AM

Update 4
- Fix cfg macro
- Fix position of bookmark image in menu
- Fix focus on new tab (the hints helped me)
- Tweaked image a bit (may broke/fix do nothing on w2k)


Quote
JohnHell
You are right but is happening with only one image, that never happened before on XP nor on 2K, in my skin. Curious. Weird. I'll send it.

Aaah, in fact the color of the first pixel of the image is used for transparency (not pink). This was done for alpha transparency to somewhat work on w2K (long ago for toolbars). You have to switch icon around so that the first icon has the first pixel transparent (pink).

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: siria
Date: August 10, 2015 04:08AM

Quote
Dorian
We're off topic but can't resist to simplify the function.
You don't need to prefix the function parameters, they can only be seen by the function.
(...)

Thank you smiling smiley
(I always struggle so hard trying to decrypt code with a flood of long variables, uff cool smiley)

Well, so this looks exactly like a normal macro to me, except for "function"...
Had initially thought this new function-stuff would require pure javascript, with all that "var xy=" stuff etc. Great that it also works with pure macrolanguage, or what I consider it ;-)
Just, where's the advantage of adding "function", hmm... multiple ARGs, right?



Edited 1 time(s). Last edit at 08/10/2015 04:14AM by siria.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Yogi
Date: August 10, 2015 05:54AM

Thanks for update 4 (fixes).

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: rodocop
Date: August 10, 2015 05:58AM

Quote
Dorian
- Fix focus on new tab (the hints helped me)

Wow! Dorian, it fixes also the sourcecode-window scroll problem!
Thank you!!!

+++
Also it seems now KM to work more smooth than previous 75.1 betas. Thanks again!


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 1 time(s). Last edit at 08/10/2015 06:04AM by rodocop.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: JohnHell
Date: August 10, 2015 06:17AM

Quote
Dorian
[...]
- Tweaked image a bit (may broke/fix do nothing on w2k)

I don't see any change.

URLs get hidden or whatever we could call that.

The magenta background for images that weren't magenta background, now are magenta background (the only one that happens).

The images in menu now don't have black background (was this corrected now, I'm loosing the track).

Quote
Dorian
Quote
JohnHell
You are right but is happening with only one image, that never happened before on XP nor on 2K, in my skin. Curious. Weird. I'll send it.

Aaah, in fact the color of the first pixel of the image is used for transparency (not pink). This was done for alpha transparency to somewhat work on w2K (long ago for toolbars). You have to switch icon around so that the first icon has the first pixel transparent (pink).

2 things:
- the image is not mine, came with the original skin (as far as I can tell as I don't have the original skin (EDIT (prior send): Here I found so blame Eyes-Only)
- ever worked till now

Said that, what do you want from me to say? :-?

Is it the first pixel to be magenta a standard for transparency? Ok, why it was working before?

One way or another, the old skinning was working as ever has worked and now doesn't. Being for this particular skin, and that particular image, or not. God, in 75.0 is working .

Was it a bad previous implementation of the transparency library? so, no my fault anyway.





Edited 1 time(s). Last edit at 08/10/2015 06:21AM by JohnHell.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: JamesD
Date: August 10, 2015 06:25AM

The URLBAR highlight color macro has been changed to use the more simple function provided by Dorian. His had a small error but that is fixed and I have also added the _() translate parts to the user interface.

https://dl.dropboxusercontent.com/u/1522294/urlbarcolor.7z

Dorian

Many thanks for the information on the argument names. Also thanks for the update 4. A lot of things work or work better now.

I did put long names matching in getpref() and alert().

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: JohnHell
Date: August 10, 2015 06:34AM

Not talking about your macro, JamesD, but an issue in 2K, absolutely unrelated (unless related to default coloring the urlbar).

EDIT: to clear it, I'm not using your handy macro.



Edited 1 time(s). Last edit at 08/10/2015 06:36AM by JohnHell.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: rodocop
Date: August 10, 2015 08:00AM

Dorian,

tell us please something about 'trusted macros'.

New KM sometimes asks about allowing macro to make changes like this



(also it happens for KM Extensions Manager macro)

If answer was 'no' - it blocks execution of macro. The new pref is created
kmeleon.plugins.macros.modules.EXTENSION_NAME.trusted
set to 2. To unblock you need set it to 1 and restart KM.

That's what I found after 1 erroneus click grinning smiley

What is that option for? And what is the trigger for it to prompt?
Very few of macros are calling this...

UPD.: Sorry - found that in the beta release notes.
So let this post remains as some 'how-to' and clarification for those inattentives like me cool smiley


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 1 time(s). Last edit at 08/10/2015 09:13AM by rodocop.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: rodocop
Date: August 10, 2015 08:22AM

And one more question about new Kmextman 8.0 for KM 7x

Is it possible to update it so it will:

1) restart only current instance of KM not all open at time (like new restart command)

2) restart on demand not auto after every extension addition (it's really inconvenient when you decide to add several extensions having big session open - even with 'lazy start')

Thank you for current update and for possible new one!
****************

P.S. One more question: how can I localize the macro info for KMExtMan?
That [info] section of corresponding ini-file from kmextensions folder...


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 4 time(s). Last edit at 08/10/2015 09:23AM by rodocop.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: rodocop
Date: August 10, 2015 09:09AM

Also I'm glad to notice that old problem of Gecko31-based K-Meleons with ISO-encodings seem to be solved in this release!

Thanks to Dorian once again!


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 1 time(s). Last edit at 08/10/2015 09:10AM by rodocop.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: siria
Date: August 10, 2015 05:17PM

Very glad to see the new version improving so much and fast, thank you! smiling smiley

Quote
rodocop
tell us please something about 'trusted macros'.
(...)
If answer was 'no' - it blocks execution of macro. The new pref is created "kmeleon.plugins.macros.modules.EXTENSION_NAME.trusted"
set to 2. To unblock you need set it to 1 and restart KM.
That's what I found after 1 erroneus click

Well, I had seen those release notes but clueless what it means exactly - what "file" functions for macros? And now your description sounds like those permissions are just normal profile prefs? If yes, and knowing that pref-toggling is one of the main jobs of macros, a malware coder would have to be pretty idiot to NOT include those permissions in the macros itself, and then the request for user-permission would only pop up for innocent macros, which gives a false impression of security. Unless there's some more checking involved, no idea...

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: rodocop
Date: August 10, 2015 07:01PM

siria,
there is also checksum-pref, that is computed in real-time I suppose.


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Zero3K
Date: August 10, 2015 10:57PM

Is anyone experiencing the wrong favicon being used for random sites? Because I am.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: rodocop
Date: August 11, 2015 01:29AM

That favicons problem was actual for 1.x versions, but now it seems to be gone for me.


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 1 time(s). Last edit at 08/11/2015 01:30AM by rodocop.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Dorian
Date: August 11, 2015 11:08PM

Quote
JohnHell
The images in menu now don't have black background (was this corrected now, I'm loosing the track).

W2k menu are working now??

Quote
JohnHell
Is it the first pixel to be magenta a standard for transparency? Ok, why it was working before?

Yes.
But bmpmenu was always using pink.
Now everything work the same.
I could force pink again, not like it matters anyways.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: JohnHell
Date: August 12, 2015 01:28AM

Quote
Dorian
Quote
JohnHell
The images in menu now don't have black background (was this corrected now, I'm loosing the track).

W2k menu are working now??

Quote
JohnHell
Is it the first pixel to be magenta a standard for transparency? Ok, why it was working before?

Yes.
But bmpmenu was always using pink.
Now everything work the same.
I could force pink again, not like it matters anyways.

Do whatever, but just remember that this is not 2K issue but XP too. Whatever was bad, was working.

The screenshot of the menu wans't from 2k but XP, and it is still XP.

Menus are fine on both except magenta background on both. If it doesn't happen on you XP (if you have a physical or virtual XP to test with), than it is my fault.


I lie myself when I say I should stop to request anything related to 2k when happens again, but, anyway: don't bother trying to fix with these problems and do what is really needed for K-meleon.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Dorian
Date: August 12, 2015 11:52PM

Update 5
- Fix: only one page was associated to a specific favicon per session.
- Fix: partial fix for windows going berserk (focus patch)

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Zero3K
Date: August 13, 2015 05:39AM

Quote
Dorian
Update 5
- Fix: only one page was associated to a specific favicon per session.
- Fix: partial fix for windows going berserk (focus patch)

I'm still having the issue with favicons not showing for certain sites/pages of sites in the autocomplete list. An example of a site not showing any favicon in it is Youtube.com.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: guenter
Date: August 13, 2015 06:35AM

Quote
Zero3K
Quote
Dorian
Update 5
- Fix: only one page was associated to a specific favicon per session.
- Fix: partial fix for windows going berserk (focus patch)

I'm still having the issue with favicons not showing for certain sites/pages of sites in the autocomplete list. An example of a site not showing any favicon in it is Youtube.com.

Which Mozilla based browser does it without fault?

p.s. AFAIK the problem is that some sites do not list the icons in the proper place.

I do not know from my own experience I base this on an old post. & HTML knowledge.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Zero3K
Date: August 13, 2015 08:50AM

Quote
guenter
Quote
Zero3K
Quote
Dorian
Update 5
- Fix: only one page was associated to a specific favicon per session.
- Fix: partial fix for windows going berserk (focus patch)

I'm still having the issue with favicons not showing for certain sites/pages of sites in the autocomplete list. An example of a site not showing any favicon in it is Youtube.com.

Which Mozilla based browser does it without fault?

p.s. AFAIK the problem is that some sites do not list the icons in the proper place.

I do not know from my own experience I base this on an old post. & HTML knowledge.

The latest version of Firefox is able to show the majority of the favicons shown when viewing Youtube.com (or its pages) in the autocomplete list.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: rodocop
Date: August 13, 2015 07:02PM

NB!!! Dear folks and personally Dorian!

I need some tests and confirmations from you:

it seems like user.js file doesn't have any effect in KM 75.1 (and maybe 75.0 too)


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 1 time(s). Last edit at 08/13/2015 07:03PM by rodocop.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: Yogi
Date: August 13, 2015 07:17PM

I've noticed as well and wondered that nobody did complain.
So I thought that it was just me.
I've deleted the existing user.js file, made a new one and it works now in both KM 75.0 and KM 75.1.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: George_Hall
Date: August 13, 2015 09:49PM

The Klassic Skin has 3 Problems in K-Meleon 75.1 Beta

The problems with the Klassic and those problemms are

1. Privacy Bar will not stay visible and disappears at starup.
(This pronlem is specific to K-Meleon 75.1 Beta>

2. When Button is unselected before the address bar in K-Meleon 75. both the "Go Buttons" and "Tab/Windows Buttons" move to left.

3. When the "Zoom buttons" is placed between to the "Search Bittons" and the "Mail/News Buttons"



The "Zoom Buttons: and some other "Toolnar Buttons" are moved at starup



Problems 2 and 3 are also prsent in previous versions of K-Meleon 75.

If the "Zoom Buttons" is placed after the "Mail/News Buttons". Then the "Zoom Bittons" are not moved at startup as well as the pther buittons.



Also as far as I know pronlems 2 and 3 only show up when the "Toolbar buttons" are locked



Edited 1 time(s). Last edit at 08/14/2015 03:12AM by George_Hall.

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: JohnHell
Date: August 13, 2015 10:14PM

No problems at all with user.js. My prefs get reset at startup. 75.0 and 75.1

Zero3k, I haven't seen any difference, but remember the preference I told in another thread: browser.chrome.favicons set to true. Otherwise only when url to favicon is set would be recognized.

George, those images are private (403 forbidden).

Options: ReplyQuote
Re: K-Meleon 75.1 Beta
Posted by: JamesD
Date: August 14, 2015 12:06AM

I concur with JohnHell. Pref that I added to user.js via edit user settings appears after a restart.

Options: ReplyQuote
Pages: Previous1234Next
Current Page: 3 of 4


K-Meleon forum is powered by Phorum.