Announcements :  K-Meleon Forum
 
Pages: Previous1234Next
Current Page: 2 of 4
Re: K-Meleon 76 Beta 2
Posted by: siria
Date: November 25, 2015 01:53PM

Quote
hermes
However, comparing with the fall of the browser and UTF-8
encoded URL, this is a problem of cosmetic nature

Sure, but cosmetics can be important too, and just for curiosity couldn't resist this purely cosmetical bad workaround ;-) It doesn't do anything to the URL itself, merely pastes the decoded URL string into the URLBAR after loading, for human readability.

(urldecode_test.kmm)

urldecode_test{ $URLBAR=urldecode($URLBAR);}
$OnLoad=$OnLoad."urldecode_test;";
$macroModules=$macroModules."urldecode_test;";

But after EVERY page load, not sure if that's a good idea, and no idea what it would do to yet more complicated characters, like chinese... Another prob: not being the real URL, bookmarks would still get the unreadable string. No idea if the new history manipulating methods could do something about that (developer.mozilla.org/en-US/docs/Web/API/History_API)



Edited 1 time(s). Last edit at 11/25/2015 02:30PM by siria.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: kmfan1
Date: November 25, 2015 03:24PM

Quote
Dorian
Quote
kmfan1
Disable menu icons and accelerators bug not fixed.

You need to refresh my memory smiling smiley

The menu icons and accelerators are always on even not enabled in options. I reported bug in first beta. Also with new profile, same. How to open Background Image in tab?

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: ngu
Date: November 25, 2015 03:39PM

Quote
Dorian
Update 1

- Fixed: session may not load.
- Fixed: possible memory corruption when reading $URL (hermes report 1)
- Added features from gestures2: draw gesture and command navSearch/ID_NAV_SEARCH (search selected text)

@hermes
Thanks for the reports.
Cyr_address: fixed
favicon_error: did some changes, not sure if that's enough to fix it.
open_file_error: no idea about this one, crash in windows dll, could be because of first bug.

Dorian, Thanks you for this great browser.

There is an enhanced mouse gesture plugin, mentioned here: http://kmeleonbrowser.org/forum/read.php?8,127127,127386#msg-127386 and here: http://kmeleonbrowser.org/forum/read.php?8,127127,127409#msg-127409 . This gesture plugin supports the so-called Super Drag, i.e. one can left-click on a link, hold the button and drag the link a little bit, then release the left button. This action will create a new TAB, background or foreground, and open that dragged link in this new TAB. I've been using that plugin all the time since k-meleon 74 beta 3. It worked fine for me until km76bu1. In recent versions of k-meleon 76, it causes many crashs of the browser. I noticed that all the plugin files were modified in these versions because the file sizes are different from old ones. I guess that's why that plugin is unstable because it is not modified. So I wonder if you could fix that? Thank you so much.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: JamesD
Date: November 26, 2015 02:36AM

Quote
kmfan1
Quote
Dorian
Quote
kmfan1
Disable menu icons and accelerators bug not fixed.

You need to refresh my memory smiling smiley

The menu icons and accelerators are always on even not enabled in options. I reported bug in first beta. Also with new profile, same. How to open Background Image in tab?

The menu icons showing when that box is unchecked seems to have begun with KM 75.1 version. It is correct in the KM 75.1 RC version.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: hermes
Date: November 27, 2015 01:24AM

Quote
JamesD
Quote
kmfan1
Also, is there a way to open background picture in tab instead of window.

I think that may require Dorian's help. In the 'menus.cfg' file the Background Image item in both Frame Properties and Page Properties menus call the Command Name 'viewImage'. This is not changed by windows diversion and I am unsure how to effect a change here.


Frame &Properties{
&Background Image=viewImage
So&urce Code=viewFrameSource
Cache &Information=viewFrameInfo
}
Page &Properties{
&Background Image=viewImage
So&urce Code=viewSource
Cache &Information=viewPageInfo
}

I have an idea how to make the preview picture as the tab,
but it does not cover the background. Create a macro file
iMAGE_as_TAB.KMM. Code:


_iMAGE_as_TAB_{
exec("\"K-MELEON\" ".$ImageURL)
}
setpref(INT,"browser.link.open_external",3)


Next, open "browser\defaults\settings\menus.cfg" and find

I&mage{

Enter a string such as:

iMAGE as TAB=macros(_iMAGE_as_TAB_)

Or modify the macro a line of the form setmenu( ...etc.



@Dorian

On systems NT6x (like Vista,7+) is ignored setting
"when closing a tab" in particular
"focus the previously selected tab" and works with
any choice like "focus the previous tab".
...
But this setup fully works on systems NT5x (like XP,2003).

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: siria
Date: November 27, 2015 03:17AM

Quote
hermes
On systems NT6x (like Vista,7+) is ignored setting "when closing a tab" in particular "focus the previously selected tab" and works with any choice like "focus the previous tab".

On my Vista32 all tab-closing options work correct.

Quote
hermes
Quote
kmfan1
Also, is there a way to open background picture in tab instead of window.

I have an idea how to make the preview picture as the tab, but it does not cover the background. (...)
exec("\"K-MELEON\" ".$ImageURL)
setpref(INT,"browser.link.open_external",3)

Yikes, exec and external links... macrolanguage is far simpler: opentab($ImageURL) cool smiley

Most of us forum regulars already have added that little function long ago, but Dorian has already posted that he'd fix it, so for once I tried to keep quiet and be a bit patient for a day or two ;-)
(PS: Macros also make no difference between foreground and background images, both are just recognized by producing a value for $ImageURL)

You're helping a lot and hope you'll stay around awhile, it just keeps fascinating me how many people are able to handle the most complicated things but have difficulty handling easy things ;-)

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: JamesD
Date: November 27, 2015 07:41AM

I know Dorian will make a better fix, but after reading the post by hermes, I had an idea. This work-a-round does work for me.

EDIT: If you got the version .6 dated 2015-11-26, don't use it. Use instead this version .7 instead. There was a bug if the page had no background image.

BkGndImgInTab.kmm

#  K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage2)
# File name: BkGndImgInTab.kmm
# ---------- Work-A-Round for opening background image in a new tab
# ---------- Open in new window, obtain URL, close window, open url in new tab
# ---------- Requirements - main.kmm
# ---------- JamesD  Version .7  2015-11-27

_BkGndImgInTab_runobtain {
$OnLoadOnce=$OnLoadOnce."_BkGndImgInTab_present1;";
$_BkGndImgInTab_url="";
$_BkGndImgInTab_wcnt=$WindowNumber;
id(ID_VIEW_IMAGE);
}

_BkGndImgInTab_present1 {
if ($WindowNumber==$_BkGndImgInTab_wcnt+1) {
$_BkGndImgInTab_url = $URL ;
$OnActivateWindow=$OnActivateWindow."_BkGndImgInTab_present2;";
id(ID_FILE_CLOSE);
}}

_BkGndImgInTab_present2 {
opentab( $_BkGndImgInTab_url );
$OnActivateWindow=gsub( "_BkGndImgInTab_present2;", "", $OnActivateWindow ); 
}

_BkGndImgInTab_BuildMenu {
	# add another option to various menus
    if ( $kTabs ) {
     setmenu("Page &Properties",macro,"Background Image to tab","_BkGndImgInTab_runobtain", "&Background Image");
     setmenu("Frame &Properties",macro,"Background Image to tab","_BkGndImgInTab_runobtain", "&Background Image");
     setmenu("DocumentImagePopup",macro,"Background Image to tab","_BkGndImgInTab_runobtain", "&Background Image");
     setmenu("FrameDocumentImagePopup",macro,"Background Image to tab","_BkGndImgInTab_runobtain", "&Background Image");     
} }

## - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
$OnInit=$OnInit."_BkGndImgInTab_BuildMenu;";
$macroModules=$macroModules."BkGndImgInTab;";



Edited 1 time(s). Last edit at 11/27/2015 03:35PM by JamesD.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: hermes
Date: November 27, 2015 06:13PM

Quote
siria
Quote
hermes
On systems NT6x (like Vista,7+) is ignored setting "when closing a tab" in particular "focus the previously selected tab" and works with any choice like "focus the previous tab".

On my Vista32 all tab-closing options work correct.


When you double click on a tab to close, the tab closes,
but the focus is does not pass on the one that was
selected before due to the allocation (from latest tabs)
that was be under cursor.
...
However, this effect does not occur when the number of tabs
sufficient to cause a sharp shift to left (by changing their
size) when you close one of them.

That is, double clicking yes closes it (an action which is
initiated by the user), at the same time it is leads to
automatic pressing at the next tab which not required (but
it turned out under the cursor).

If you dont use mouse for clossing tab (as example: a menu
icon, a close button on the tab, the keyboard shortcut)
this effect is not observed.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: siria
Date: November 27, 2015 06:30PM

Strange... I usually close tabs by middleclick, and used about 6 tabs yesterday for testing, making sure the previous-used one was far enough away. That way all worked fine.
No time to test again right now, but perhaps there's some issue with double-clicking, your posting sounds like it possibly 3x-clicks??

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: hermes
Date: November 27, 2015 08:52PM

Quote
siria
... but perhaps there's some issue with double-clicking, your posting sounds like it possibly 3x-clicks??

Averaging: two clicks works as three. But not always.
The number of tabs is important. The effect is almost
unnoticeable in a more than 10-11.
...
Tested this using real clicks and virtual (SendMessage
like WM_LBUTTONDOWN / WM_LBUTTONUP and mouse_event...).

Quote
siria
I usually close tabs by middleclick ...

Works great, but the question about the double click.

Two not to be anyway three.

This is only a small remark. If possible to correct well,
no it's quite tolerable.
Quote
siria
... but cosmetics can be important too ...


Another question: why RButton LButton = tabClose ignored as a team?



Edited 5 time(s). Last edit at 11/28/2015 10:14AM by hermes.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: siria
Date: November 28, 2015 06:48PM

@hermes
The tab handling seems to be independant from the normal shortcut keys. Am using middle-click to close tabs AND using middle-click to open links in a new tab at the same time, without changing anything.
Just customizing mouse on tabs here:
Edit > Configuration > Browsing > Tabbed Browsing >> Tab Bar
There at the bottom is configuration for mouse on tabs, for double / middle / right clicking.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: Dorian
Date: November 29, 2015 03:34AM

Quote
kmfan1
The menu icons and accelerators are always on even not enabled in options. I reported bug in first beta.

Ok for menu icons, they're not really supposed to be removable anymore. But accelerators are correctly removed, except for some item that need a restart (which looks like a windows mystery).


Quote
ngu
There is an enhanced mouse gesture plugin, mentioned here:

That's gestures2 for me.
Even it it works for you, superdrag is broken in this plugin.
If there is no problem with the current plugin, depending on my time, I'll fix gestures2, or implement superdrag properly in the official plugin. Superdrag extension for firefox could be adapted for kmeleon too I think.


Quote
hermes
When you double click on a tab to close, the tab closes,
but the focus is does not pass on the one that was
selected before due to the allocation (from latest tabs)
that was be under cursor.

There is no easy way to fix it currently because of how kmeleon handle tabs.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: JamesD
Date: November 29, 2015 05:12AM

Quote
Dorian
Quote
kmfan1
The menu icons and accelerators are always on even not enabled in options. I reported bug in first beta.

Ok for menu icons, they're not really supposed to be removable anymore. But accelerators are correctly removed, except for some item that need a restart (which looks like a windows mystery).

I think then the item in PREFERENCES > GUI APPEARANCE > GENERAL > SKIN which has a checkbox for "Display menu icons" should be removed. It gives the impression that the option is available.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: jasonliul
Date: November 29, 2015 11:21AM

Sometime download windows just disappear without reason, retry then OK.

Some forum post editor doesn't work, KM74 works fine.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: hermes
Date: November 29, 2015 11:22AM

Quote
JamesD
Quote
Dorian
Quote
kmfan1
The menu icons and accelerators are always on even not enabled in options. I reported bug in first beta.

Ok for menu icons, they're not really supposed to be removable anymore. But accelerators are correctly removed, except for some item that need a restart (which looks like a windows mystery).

I think then the item in PREFERENCES > GUI APPEARANCE > GENERAL > SKIN which has a checkbox for "Display menu icons" should be removed. It gives the impression that the option is available.

Why? No need to remove this setting. It is fully functional, but only for classic skin. This is useful. No one uses classic skin? sad smiley

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: rodocop
Date: November 29, 2015 08:47PM

I do use old classic skins for sure.


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: JamesD
Date: November 29, 2015 08:50PM

Quote
hermes
Quote
JamesD
Quote
Dorian
Quote
kmfan1
The menu icons and accelerators are always on even not enabled in options. I reported bug in first beta.

Ok for menu icons, they're not really supposed to be removable anymore. But accelerators are correctly removed, except for some item that need a restart (which looks like a windows mystery).

I think then the item in PREFERENCES > GUI APPEARANCE > GENERAL > SKIN which has a checkbox for "Display menu icons" should be removed. It gives the impression that the option is available.

Why? No need to remove this setting. It is fully functional, but only for classic skin. This is useful. No one uses classic skin? sad smiley

You are correct. It does work for all skins using the bmpmenu plugin.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: aimfiend
Date: November 29, 2015 09:11PM

since version 76beta , "continuous reload" not working, showing only blank page with meaningless couter,although version 75.1 works fine mad smiley

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: kmfan1
Date: November 29, 2015 10:38PM

Quote
JamesD
Quote
hermes
Quote
JamesD
Quote
Dorian
Quote
kmfan1
The menu icons and accelerators are always on even not enabled in options. I reported bug in first beta.

Ok for menu icons, they're not really supposed to be removable anymore. But accelerators are correctly removed, except for some item that need a restart (which looks like a windows mystery).

I think then the item in PREFERENCES > GUI APPEARANCE > GENERAL > SKIN which has a checkbox for "Display menu icons" should be removed. It gives the impression that the option is available.

Why? No need to remove this setting. It is fully functional, but only for classic skin. This is useful. No one uses classic skin? sad smiley

You are correct. It does work for all skins using the bmpmenu plugin.

Something not right. Test with Klassic, icons removed but reserved place for icon with no display which ugly long menu and accelerators always there, I tested after restart. So it is option removed or bug ignored on porpose? It's K-Meleon or Maxthon? No matter, I stay with 75 with no bugs, I mean "option removed".

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: siria
Date: November 30, 2015 01:15AM

Just a bit testing, on Vista32, no aero:

When menuicons and shortcuts in menus are off:

KM75.0:
both skins, default+klassic:
- Right side smaller, no empty dummy space left
- Left side space reserved for checkmarks, about 1mm smaller as for icons.
- NO icons shown for macros using setcmdicon

KM75.1+KM76b2:
both skins:
- too much space on right side, where shortcuts are hidden
- icons by macros using setcmdicon are visible in both skins
default skin: ALL icons visible
Klassic skin: no icons except macro-icons, but 1mm more space on left side if an icon was hidden (not something that would give me sleepless nights cool smiley)

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: kmfan1
Date: November 30, 2015 02:31AM

Quote
siria
Just a bit testing, on Vista32, no aero:

When menuicons and shortcuts in menus are off:

KM75.0:
both skins, default+klassic:
- Right side smaller, no empty dummy space left
- Left side space reserved for checkmarks, about 1mm smaller as for icons.
- NO icons shown for macros using setcmdicon

KM75.1+KM76b2:
both skins:
- too much space on right side, where shortcuts are hidden
- icons by macros using setcmdicon are visible in both skins
default skin: ALL icons visible
Klassic skin: no icons except macro-icons, but 1mm more space on left side if an icon was hidden (not something that would give me sleepless nights cool smiley)

More than 1 mm with no aero. You not think about screen resolution, may be you using small notebook computer?when monitor is bigger it is like 5 mm.

Then problem a bug should fix not say option removed and other bug of accelerators always on. There's great saying " if it is not broken do not fix it" but first background image from 74 now in open window instead of tab... why? then from 75 to 76 icons and accelerators bug so much spaced menu and now it is option removed... why? it work in 75. it work in 74. Toolmenu was removed from 1.6 but option to re-enable it, ok? is K-Meleon trying to be like Chrome? browsers than want same look and function on computer and smartphone with material design but K-Melon for computer only, why try to be like others?

Now 1mm, you can sleep, good... but it's not only made for you? next release this bug ignorned then toolmenu option removed also or something else. Then finally is just like others. Not innovative, just broken! The browser you control? may be motto should change too.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: rodocop
Date: December 01, 2015 03:45AM

KM76b2u1 & KM76b2

Very strange glitch with History options:

1) calling this from History button right-click sometime (not always) opens History options without settings not shown there (boxes are empty);
2) switching language to russian (and back to English) frequentl leads to autoclose of Preferences window
and if Pref window was called by History button right-click lang switch mostly leads to autoclose KM too (crashrpt.dll cannot catch this crash)
3) switching langs leads time to time (without obvious algorhythm) history options be empty (see 1)
4) small hack of history.xul or places.kmm leads to History options being empty in Russian (no history-overlay displayed at all - just grey background).

If places.kmm was hacked ('opennew' replaced with 'opentab') - then all can be good after restart. Or can be not.

If I change history.xul
(line 17 slightly edited deleting first onLoad event:
from: onload="window.sizeToContent();HistorySidebarInit();"
to: onload="HistorySidebarInit();" )

than History options in Russian stay empty-gray forever.

I understand that this is very unclear report, but I cannot make it easier.

But I was able to catch and report one crash with plugin (if I'm not wrong - number 2038)


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 1 time(s). Last edit at 12/01/2015 03:46AM by rodocop.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: rodocop
Date: December 01, 2015 03:58AM

Update:

my first report was #2083

And now #2084 was also reported (with no KM files changed out of the official box): Russian History options were empty&gray and crash was after switching lang to en


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 1 time(s). Last edit at 12/01/2015 03:58AM by rodocop.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: siria
Date: December 01, 2015 07:56AM

The last months I keep constantly running into weird probs with macrostuff, and sooner or later always getting stuck and give up sad smiley
Just quick from memory, latest discovery, after opening a popupmenu using "rebarmenu" (and it opens macros containing $ARG, no idea if matters), it seems impossible to have it reload a page in whatever way, not even by open(url)! It just keeps opening a new TAB. Using "popupmenu" works okay, but it just means old macros break easier.

A major prob are now portable links inside KM folder:
resource:/// opens now in root/browser, and again find no way to step one level higher into KMroot. For new macros can partly use workaround via getfolder(rootFolder), but again see probs with older macros, and independant files like css etc. still cannot use local links directly, without additional "path translation" by macro.

And encoding is weird now, since 7X. injectCSS works best when NOT using readfile(*.css) first, or the css file must NOT have that BOM marker with utf-8. Even without it, completely harmless short style snippets sometimes stop working if placed at end of file and not beginning, although there's not a single non-ascii character in the whole file. And it seems to make a difference now if a readfile-path starts directly with a subfolder, or has getfolder(rootFolder) as prefix. Stuff like that makes no sense at all to me, but encoding is a very chaotic field, would probably require a testing macro again. And of course am still testing cross-version with 74-76, additionally confusing swiss-cheese-memory with all the version specialities tongue sticking out smiley

Ah and another weirdness, pictures get all auto-zoomed now. No chance to see an image 1:1 and sharp like in irfanview, KM stubbornly zooms everything now, looks washed out, and is a LOT bigger :-/ May also causes probs if someone, or older macros, need to calculate with screen size in pixels, that doesn't match anymore.

Am aware that's just a bunch of chaotic remarks, sorry, but don't have more details yet.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: hermes
Date: December 01, 2015 06:56PM

It seems to me the plugin "crash report" must be run in a separate process.
Otherwise he will not be able to survive after the full fall of the browser
and make a report / dump. So I can not send many crash reports because the
browser falls sometime.



Edited 1 time(s). Last edit at 12/01/2015 07:14PM by hermes.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: Zero3K
Date: December 01, 2015 11:26PM

Twitter.com isn't working properly for me. I can't post a new tweet, etc. while using the latest update.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: JohnHell
Date: December 01, 2015 11:50PM

@Siria, for the images, I'm not sure what do you mean. I haven't seen them auto-zoomed from 74 to 75 (76 should be doing the same).

But if it is because the images look blur, it is by this:
https://developer.mozilla.org/en/docs/Web/CSS/image-rendering

Mozilla decided to use bilinear filtering for every image.

To override, set in userContent.css to crip-edges or whatever. I have it set like crisp-edges since K-meleon 74 as I NEED TO SEE THE PIXELS as I need them for the sites I visit.



Edited 1 time(s). Last edit at 12/01/2015 11:51PM by JohnHell.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: rodocop
Date: December 02, 2015 12:55AM

Zero3k,
cannot confirm Twitter probs. All works fine.

JohnHell,
could you please post exact css-code needed for crisp pixel view?


Latest Release KM75.1 Latest dev KM76RC ||| Visit The K-Meleon Place and join me there!
Old good stuff: KM-1.6db+NS © dugbugoffice // KM-16-S2014 © Fred // KM-1.6beta2.6 © JamesD // KM Twin+ © rodocop // KM 1.8.24.22 © adodupan

RECOMMENDED! K-Meleon 76 Pro ==» Download portable: 7zip or EXE =//= Discuss on forum
K-Meleon 75.1 Pro: Download =//= Discuss || Portable Flash plugin (x86/x64 DLLs)



Edited 1 time(s). Last edit at 12/02/2015 12:55AM by rodocop.

Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: JohnHell
Date: December 02, 2015 01:51AM

If you want to let some sites to use their interpolation code (for some special webs), remove the !important:

img{image-rendering: -moz-crisp-edges!important}


Options: ReplyQuote
Re: K-Meleon 76 Beta 2
Posted by: siria
Date: December 02, 2015 01:59AM

Quote
JohnHell
@Siria, for the images, I'm not sure what do you mean. I haven't seen them auto-zoomed from 74 to 75 (76 should be doing the same).

But if it is because the images look blur, it is by this:
https://developer.mozilla.org/en/docs/Web/CSS/image-rendering

Mozilla decided to use bilinear filtering for every image.

To override, set in userContent.css to crip-edges or whatever. I have it set like crisp-edges since K-meleon 74 as I NEED TO SEE THE PIXELS as I need them for the sites I visit.

Looks interesting, and I roughly understand what it does (like the zooming options in irfan view, View>Display Options>Use resample). Might come in handy some other time.

But no effect for this auto-zoom thing, about 135% here. Theory: perhaps the same reason as auto-zooming of toolbar buttons, depends on screen dpi? Would fit, because my vista-monitor has rather tiny pixels. And basically it would be a cool function, if only there was a pref to toggle it on/off, depending on user preference cool smiley
And I can rule out that the images are zoomed any other way, not by css nor by page-zoom, and the image properties also indicate no scaling. Even when opening a pic standalone, with *.jpg in the urlbar.
For the moment have added a fix multiplicator in the current little macro, just for testing how it looks.

Options: ReplyQuote
Pages: Previous1234Next
Current Page: 2 of 4


K-Meleon forum is powered by Phorum.