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General


 



What is K-Meleon?

K-Meleon is a lightweight, customizable, open-source  web browser. It's designed for Microsoft Windows (Win32) operating systems. K-Meleon can use the secure Goanna engine based on Mozilla's Gecko layout engine or Gecko itself. The popular web browser Firefox also uses Gecko. K-Meleon uses the native Windows (Win32) API for its interface unlike common multi-platform browsers. K-Meleon offers tremendous customization options to end users, uses no telemetry, and requires minimal system resources.





 



What platforms does K-Meleon run on?

K-Meleon is designed for Microsoft Windows (Win32) operating systems. Current 64-bit versions of Windows are backward compatible and will run K-Meleon. The oldest version of Windows officially supported is Windows XP. There is an unofficial port of K-Meleon 74 for Windows 2000 available.Check the forums for updates and support on the Windows 2000 build. Older versions supported Windows 9X systems and there is a Windows 98 version patched for TLS.




On Linux and other unix systems, K-Meleon must run via Wine or in a Windows Virtual Machine. For more information visit the forum for Linux Users. The older unofficial builds for Linux, like Fred's Unofficial K-Meleon variations don't use a current release of K-Meleon. Android is not natively supported. 





 



What are the system requirements?

Active 76.X.g Goanna-based branch:



  	 Windows XP Service Pack 3 or newer (Windows 2003, Vista, 7, 8, 8.1, 10, and 11 are all supported)
	 250 MB RAM
	 100 MB disk space
	 SSE not required.  




K-Meleon 75 (last official release):



  	 Windows XP SP2 or newer 
	 70MB disk space (more info in the Release Notes 75.)  




K-Meleon itself can run on as little as 20 MB of RAM, but web pages will often require more. It's possible to run K-Meleon 76 on Windows XP SP2 using a kernel replacement. (More details in forum: http://kmeleonbrowser.org/forum/read.php?19,145119 ) Older versions of K-Meleon will run on even older systems, but do not receive security updates or bug fixes.





 



What is new/improved/fixed in the latest version of K-Meleon?

Please consult the release notes in the forum for the active branch or the release notes for older official versions of K-Meleon. Active development is focused on improving the web engine and improving security. 





 



How do I install/uninstall K-Meleon?

Please consult the InstallationGuide for instructions on installing, uninstalling, and updating K-Meleon. For additional support, vist the forums.




 



How do I set K-Meleon as default browser?

Go to  Edit > Preferences (F2) >> Browsing and click Set as Default Browser. 
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Does K-Meleon support current Web standards?

Yes, K-Meleon can use the Gecko rendering engine developed by Mozilla, which is also used by Firefox or the secure Goanna engine. Both engines support current (X)HTML, CSS and DOM standards. K-Meleon does not support some recent technologies from Google including WebRTC, EME-based DRM, or shadow DOM.




 



Does K-Meleon support secure (encrypted) transmissions?

Yes, K-Meleon supports  SSL and TLS.




 



Does K-Meleon support tabbed browsing?

Yes. You can configure tabs at Edit > Preferences (F2)  >> Browsing  > Tabbed Browsing  >  Tab Bar.




 



Does K-Meleon support Java?

Yes, K-Meleon is one of the few browsers to still support NPAPI plugins like Java. K-Meleon automatically detects if the Java plugin is installed on your computer. To see if you have Java go to Help > About Plugins'. For more information visit the JavaPlugin page. You can also check out the PrivacyTutorial for tips on how to restrict most websites access to the plugin.





 Note: Java may not work when you change K-Meleon's browser identification (UserAgent) string.




 



What is the K-Meleon Loader? 

The K-Meleon Loader preloads portions of the K-Meleon browser to launch more quickly. In current versions of K-Meleon the loader must be set up manually. Older versions of K-Meleon used a slider to detemine how much of K-Meleon would be pre-loaded. Since K-Meleon 76.x the slider only turns the loader on or off. Some versions of K-Meleon (74 and 75) do not include the loader at all.  Be aware that the K-Meleon browser keeps running as long as the K-Meleon Loader is running. Some changes to the configuration of K-Meleon will not take effect until you close and restart the browser. When using it, you also have to close and restart the Loader to make such changes take effect. 




 



What privacy features does K-Meleon include?

K-Meleon is free of the telemetry that common browsers abuse. It also defaults to the privacy-focused DuckDuckGo search engine. K-Meleon's unique Privacy Bar can block Java, Javascript, popups, cookies, and images with a single click. To enable it, go to View > Toolbars > Privacy Bar and click to activate.




You can manage cookies through Edit > Preferences. K-Meleon's UserAgent string can be quickly changed through Tools >User Agent. To clear private data in the cache, cookies, history or passwords automatically go to Tools > Privacy > Clear Data. You can even set up mutiple profiles with different levels of security. 




For more information check out the PrivacyTutorial.




 



Why does K-Meleon not include feature "X" (e-mail client, etc.)?

K-Meleon is intended to be a fast, customizable, lightweight web browser. It is designed to be a browser only, not a suite. Thus, it does not include features such as an e-mail client or a web page editor, which could bloat and slow K-Meleon down. Users are encouraged to use their favorite applications for these and other particular purposes. The K-Meleon developers will consider enhancements that improve the performance and usefulness of the browser.
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How do I use my existing Bookmarks?

K-Meleon defaults to using Netscape-style bookmarks. The first time K-Meleon is run with the Netscape Bookmark Plugin enabled, it automatically creates a new bookmarks file in your profile directory. Netscape-style bookmarks have become a standard method of exporting bookmarks across web browsers. If your browser offers a way to export bookmarks to an html file, it's compatible with K-Meleon.




To use existing bookmarks, export your bookmarks to an html file, open K-Meleon, go to Edit > Preferences > K-Meleon Plugins > Netscape Bookmarks and select Netscape Bookmarks File section. Click on Browse. Set the location to your html bookmarks file. 




 



How do I use my existing Internet Explorer Favorites?

K-Meleon's IE Favorites Plugin automatically locates and uses your Favorites. This plugin does not import your Favorites, it allows you to sync your Favorites between K-Meleon and Internet Explorer!




You can also import your bookmarks into K-Meleon's normal bookmarking system. Just activate Netscape Bookmark Plugin in preferences, go to Bookmarks > Edit... and then press Import Favorites.




 



Can I sync with Opera Hotlist?

K-Meleon still retains a Kplugin to sync with early versions of Opera's hotlist. If you are you using Opera 12 or higher, you will have to import your bookmarks as an html file using the Netscape Bookmarks Plugin.




 



How do I Backup my Bookmarks or Favorites?

 Backup Favorites: 

Click Favorites > Edit or right-click the Favories icon to open your file explorer to the Favorites folder. Right-click on your Favorites folder to copy and paste it elsewhere. If you see only the sub-folders, navigate up one level. 




 Backup Bookmarks or Hotlist: 

If you use the default location, click Edit > Configuration > Profile Directory to open your currently used K-Meleon profile folder. Copy the file "bookmarks.html" or "opera.adr" (=hotlist) to any location you wish. To later restore, just copy it back.

You can also simply copy it renamed into the same folder, just keep in mind, if you accidentally delete this profile later, this backup would be lost too.





 Backup Bookmarks or Hotlist with non-default path: 

If you have set another path for your bookmarks or hotlist (perhaps to share them with another browser), click Bookmarks > Options or Hotlist > Options to find its location in the file field. Open your file explorer to copy and paste that file elsewhere.

(Highlight and right-click to copy that path. Open your file explorer, paste the path into the address line and crop the filename (after the last "\"), hit Enter to open that folder. Find your bookmarks or hotlist file there and copy it to another location. Tip: Or in the Options tab just click "Browse", right beside the path field, and paste the cropped folder name into the "filename" field to open that folder)




 



How do I search inside my Bookmarks, Hotlist or Favorites?

 Bookmarks or Hotlist: 

Press Ctrl+B or right-click to open their menu and choose Edit.... Then begin typing; there is no search field. To jump to the next bookmark, press F3.

(This works on-the-fly, already while you're typing it's jumping to the first matching bookmark. Note that only text in the first (x?) characters of a bookmark is found. Remember F3 means "Find Next" in most windows programs. Tip: Right-click on a bookmark for more options, e.g. to create subfolders.)




 Favorites: 

Click Favorites > Edit... The favorites folder will open in the file explorer of your system. As usual in windows programs now click Ctrl+F (or use menu) to search in it with your build-in file search. All hits will be listed together.

(You can also open a subfolder first, if you only want to search inside that one. Or right-click on a folder and find a Search command in the context menu, along with other options to rename or change the target URL etc. Note that this is just basic Windows stuff which has nothing to do with the browser, all KM does is call the file explorer. A double-click on a found Favorite will open it in the browser which you have set as default in your system.)




 



How do I open all Bookmarks in a folder at once?

Edit your Bookmarks or Hotlist and fill in the Nick field of a folder. Then if you want to open all those pages later, just type the nickname into the URL bar and press Return. Also works for single bookmarks, also for "Hotlist", but not "Favorites".




 



What are Hotlinks?

Hotlinks are provided through the Macro Extension Plugin and are in a way K-Meleon's own bookmarking system. Very simple, yet efficient. Through Tools > Hotlinks... you have the possibility to assign a URL to each of the key combinations Ctrl+0, Ctrl+1, ..., Ctrl+9. 

Note that javascript: URLs (bookmarklets) usually won't have the desired effect when set to open in a new window/tab.

Hotlinks are not stored in a separate file, they are part of prefs.js in your current profile folder.
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What do the default Kplugins do?


  	adblock
	 The built-in adblocker can be run with an extension like AdBlock Locus or set up manually in the adblock.txt file.
	Bitmapped Menus
	 Displays icons in menus.
	External Control Plugin
	 Allows programmers to interface with K-Meleon from within their own programs.
	Fullscreen Plugin
	 Adds support for full screen display.
	History Plugin
	 Allows to view the global history and adds right-click menus to the back and forward buttons.
	IE Favorites Plugin
	 Provides support for Internet Explorer Favorites.
	KMeleon JS Bridge
	 Allows XUL applications to create K-Meleon interface elements like menus. 
	Layered Windows Plugin
	 Simulates tab-like behavior by grouping windows together and keeping most of them invisible. (Obsolete since K-Meleon 1.5)
	Macro Extension Plugin
	 Adds macro language support which enables many additional features in K-Meleon. You'll find examples in the macro library.
	Mouse Gestures Plugin
	 Adds the ability to perform commands and macros with a combination of mouse movements and right clicks. Configurable through Tools > Mouse Gestures....
	Netscape Bookmark Plugin
	 Provides support for Netscape/Mozilla-style bookmarks, incl. older Firefox versions bookmarks. In Firefox 3.x "Export to HTML" your bookmarks to convert them to the traditional (KM-compatible) mode.
	Opera Hotlist Plugin
	 Provides support for Opera-style bookmarks (Hotlist).
	Privacy Plugin
	 Allows to clear privacy-related data (cache, cookies, history and passwords) etc.
	Rebar Menu Plugin
	 Makes the menu bar a toolbar. This will allow you to move the menu bar around just like a normal toolbar, but this may break compatibility with screen-readers.
	Session Saver Plugin
	 Allows to save and restore sessions, and to "Undo Last Closed" pages (e.g. if you accidentally closed it)
	Toolbar Control Plugin
	 Provides support for customizable toolbars. See also the K-Meleon Themes.  




 



How do I enable/disable a Kplugin?

Open Edit > Preferences (F2) >> K-Meleon Plugins in preferences. Select the plugin in question and press Enable/Disable. A checkbox indicates that a plugin is currently loaded. Click on Macro Extension to find the list with checkboxes for single macros. Checked plugins and macros will be loaded next time K-Meleon starts.




 



How do I make K-Meleon use a third party NPAPI Mozilla plugin?

K-Meleon automatically detects the Adobe Acrobat Reader, Java Runtime Environment, Apple QuickTime and Windows Media Player plugins. Flash and Shockwave setup programs automatically detect K-Meleon.




If it's not working automatically, any Mozilla plugin should work by being copied into K-Meleon's plugins directory (not kplugins directory), which is located in the K-Meleon installation directory. You can check the status of any plugin by opening Help > About Plugins. All your plugins currently used by K-Meleon will be listed there. You can manage plugins from the about:addons page. For more information please review the page about third party plugins.




 



Why can't K-Meleon open PDF files with my plugin?

To set up a PDF reader in K-Meleon use the instructions on the PDF reader plugin page. There are several options for K-Meleon including Foxit, SumatraPDF, and pdfjs.




If you're having trouble with a plugin already on your computer, read this forum thread for tips.
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Does K-Meleon support skins/themes?

Yes. You can download skins from the K-Meleon Forum or the K-Meleon Themes Wiki. To install a skin, simply extract the provided  archive into K-Meleon's skins directory, and restart K-Meleon. You can change skins in Edit > Preferences (F2) >> GUI Appearance. You can also choose to display menu icons, the throbber, or the toolbar background. Check out the Skinning and Theming Tutorial for more information.




Tip: To customize the toolbar background, just take any image you like, open it in your image editor, save it as "back.bmp" in the current skin's folder, and restart K-Meleon.





K-Meleon themes will define which toolbars and toolbar buttons are available, but don't affect menus. To add custom menu entries, click Edit > Configuration > Menus. Refer to ConfigFiles for more information.





 



How to hide some buttons, or get more?

Single toolbars can be switched on or off in View > Toolbars. Have a look at the Privacy toolbar if you often toggle javascript, cookies, etc. Have you discovered the right-click menus on Go, Home, Close Tab, and other buttons? There are many additional functions there.




To show or hide single buttons, click Edit > Configuration > Toolbars. This will open toolbars.cfg in a text editor. It's not as scary as it looks at first. You can just add #-comment-signs to hide a button or remove them to show a button. Be sure to save a copy before editing in case you run into errors.




You can customize everything in toolbars.cfg, including creating your own buttons, making new toolbars, changing left-click commands, and changing right-click menus for every button. Refer to the Skinning and Theming Tutorial for more information, and feel free to post in the forums if you have any questions.




 



Does K-Meleon support command line options?

Yes. Please review the page about command line options.

For example you can add " -new" in the shortcut to open a second browser instance that runs independendly with another profile, or simultaneously run different K-Meleon versions. Or include different profile versions in your shortcut icons. Or run KM in kiosk mode.




 



Does K-Meleon provide localization/multi-language support?

Yes. K-Meleon automatically attempts to recognize documents' character sets and display them properly. The browser's user interface is fully translatable since version 1.0 and supports multiple languages since version 1.1. Press F2 to open the preferences and change the language for the browser's interface.




Official localizations and language packages (to be installed additionally) can be found in the DownloadsArchive. If you're interested in creating your own translation/localization, please refer to the Localization page.




TIP: Some websites offer different language versions, but depending on your browser settings. If you speak another language than english, check if you see the country flags under the menu on the left side here? Do they vanish if you click english? Then change this setting: Open "about:config" page, ignore the warning this time, and filter for "lang". This line is important:

 "intl.accept_languages"
Right-click and set it to something like "en-us, en, de, fr, es", depending on your languages, and the flags will show up again, and stay now.




 



Does K-Meleon allow to middle-click links to the background?

Yes. Mouse accelerators such as MiddleClick, Ctrl+LeftClick, Ctrl+RightClick to open links in new (background) 
tabs, can be configured quickly throug Tools > Mouse Accelerators. Simply choose the configuration that best fits your needs:


	   	 Default 	 Firefox 2.0 	 SeaMonkey 1.1 	 Opera 9.2 
	 Ctrl+LeftClick 	 Open in foreground 	 Open in background 	 Open in background 	 (nothing) 
	 Shift+LeftClick 	 Open in foreground 	 Open in new window 	 Save link target 	 Open in foreground 
	 Ctrl+Shift+LeftClick 	 (nothing) 	 Open in foreground 	 Open in foreground 	 Open in background 
	 Alt+Shift+LeftClick 	 (nothing) 	 (nothing) 	 (nothing) 	 Open in foreground 
	 Ctrl+Alt+Shift+LeftClick 	 (nothing) 	 (nothing) 	 (nothing) 	 Open in background 
	 MiddleClick 	 Open in foreground 	 Open in background 	 Open in background 	 Open in background 
	 Shift+MiddleClick 	 (nothing) 	 Open in foreground 	 Open in foreground 	 (nothing) 
	 Ctrl+RightClick 	 Open in background 	 Open in foreground 	 Open in foreground 	 (nothing) 




 



How can I open external links in a new tab instead of a new window?

Open Edit > Preferences (F2) >> Browsing and click the Window Diversion tab. Under Open, choose URLs passed from external applications and click in a new tab. Now links in emails or local html-files will open in a new tab.




 



How to automatically restore all windows and tabs from the last session?

To always start with the previous session, select Sessions > Options..., click Open the following session at startup, and choose Previous Session. Or right-click the Home button, select Start with Session, and choose Previous Session.




To manually start with the previous session, select Sessions > Load Session > Previous Session. Vist the forum for more information: http://kmeleonbrowser.org/forum/read.php?4,140604




 



How do I customize shortcut keys?

You can customize shortcut keys (or accelerators) by editing the accel.cfg file in your profile folder with any text editor. To edit the config file, select Edit > Configuration > Accelerators from K-Meleon's menu. For an explanation of syntax, refer to the Configuration Files page.




 



How do I set up macros?

K-Meleon provides support for macros, a simple type of human-readable extension.




You can install a K-Meleon macro module (.kmm) by placing it in your K-Meleon/macros/ folder. To open the macros folder, select Edit > Configuration > Macros. You can also store macros in your profile by creating a K-Meleon/Profiles/your.profile/macros/ folder. If macros with the same name are stored in both the program folder and the profile folder, K-Meleon will always use the macro from the profile. This will work even if the individual macros are stored in differently named .kmm modules. Storing custom or downloaded macros in your profile makes it easier to transfer your macros to new K-Meleon installations when you update K-Meleon or switch to another computer.





To toggle macros, open Edit > Preferences (F2) >> Macro Extension and click the macro's name. 





User-submitted macros are available in the:



  	 Extensions forum
	 Extensions Central archive
	 Macro library  




 To uninstall completely, delete the .kmm file and, if it was part of a more complex extension with several files, delete those too. 




 K-Meleon Extensions are often offered as .7z archives containing macros and other tools/graphics. They install automatically if you unzip them to the K-Meleon root folder. Refer to the extensions page for more information.




 If you'd like to modify a macro yourself, open the kmm file in any text editor like Notepad or the open-source Notepad2. Be very careful with the code syntax, but a few things are rather harmless like changing path names for files, modify or hide single menu entries, shortcut keys etc. Important for special characters: the kmm encoding must be UTF-8. Make a backup copy of the kmm first, and don't hesitate to ask in the forum if you have questions.




 



How do I set up profiles?

Profiles can be added, deleted and renamed using the profile manager. Just click Edit > Manage Profiles... in K-Meleon's menu. You can create as many profiles for a user as you like. When creating a new one, check Ask at Startup so you'll be able to select it.




If you do not want your profile folders placed in your windows user appdata folder (multi-user profile), but inside the K-Meleon program folder (single-user/portable version), you need an empty "profile.ini" file in the K-Meleon root folder. (The active branch release are distributed as .7z files already set up in this manner.) If this file exists, K-Meleon will create new profiles under K-Meleon/Profiles. Note that you must have write permissions for the folder.




For advanced profile customization, you might want to review the details on profile location.




You can copy the contents of one profile folder into another. For example bookmarks.html contains all of your bookmarks and prefs.js contains all of your custom settings (all of the bold entries that you see in about:config). Refer to MigratingProfiles for more information. 




 



How do I configure proxies?

Select Edit > Preferences (F2) >> Network/Performance > Proxy in K-Meleon. 




K-Meleon only accepts hostnames for manual proxies. For older proxies that do not support the most recent HTTP specification, you can set K-Meleon to use HTTP 1.0 instead of 1.1 on the General tab in Preferences. There is a step by step guide to set up Privoxy to block ads locally.




Through Tools > Proxy you can quickly switch between several proxy settings. Note that the custom proxy settings are currently limited to the HTTP protocol.




For more information check out the proxy setup tutorial.




 



How do I put the Tab bar on the bottom?

Select Edit > Preferences (F2) >> Browsing > Tabbed Browsing > Tab Bar. Then, click the box beside Display tab bar: and choose on bottom. Do not set minWidth for tabs smaller than 8, or you risk crashes.




Often overlooked: You can also set your preferences there for left/middle/right-clicking on a tab. You can change it if, for example, you want to close tabs with a middle-click or open new ones with double-click. 



Note for bottom tabs (as of Aug.2010):

In K-Meleon 1.6 the prefs entry for bottom tabs changed. If you use a profile from 1.5.X that was customized to use bottom tabs, without "Tab/Window buttons" attached, the browser may crash at startup. To fix this, delete "kmeleon.tabs.bottomBar" from prefs.js in your profile.


Obsolete: To set "layers" to the bottom, look at the K-Meleon Preferences page. But it's been awhile that layers (pseudo-tabs) have been replaced with "real" tabs in K-Meleon.




 



How to get a close button (X) in each tab?

In K-Meleon, go to Edit > Preferences (F2) >> GUI Appearnce > Toolbars to open the preferences dialog. Open the Tab Bar tab and select Show Closing Buttons on the tab buttons. Restart K-Meleon for changes to take effect. 




 



How do I change default background color in pages or new tabs?

Three different ways are possible:





 A) userContent.css

In K-Meleon, select Edit > Configuration > User-Defined Stylesheet to open userContent.css in a text editor. Copy and paste one of the following rules, then save the CSS document, and restart K-Meleon.





To only affect empty browser windows:




@-moz-document url(about:blank) {
body { background-color: Window; }
}





To affect only pages that do not have a background color:




body { background-color: Window; }





To affect all pages:




body { background-color: Window !important; }





'Window' is the symbolic name for your OS's window color, whatever it actually is. Any valid CSS color will also work. You'll have to restart K-Meleon for changes to userContent.css take effect.





 B) about:config

Alternatively you can change a pref entry. This will affect empty browser windows/tabs, and all pages that do not have a background color set: 




  	 Go to Edit > Configuration > Browser Configuration or type about:config into the address bar
	 Click I promise to be careful! on the warning screen.
	 Type color in the search box.
	 Right-click on browser.display.background_color and set another color value in the format #XXXXXX (#RGB, 0-F). 
	 Open a new page or reload to see the new color (no restart needed).  




Optionally, you can FORCE this color on all elements, not just the ones the author left undefined, by clicking Block Page Colors under Tools > Privacy in K-Meleon. Be aware that this one also forces own colors for text and links and it will also hide all background images, probably useful only in special cases.

There are tons more native gecko prefs available in about:config, more info is available on the Mozilla website




 C) Macro extensions, addons etc.

You can also modify styling by using the injectCSS command from custom macro extensions. Refer to the macro tutorial and macro language reference for more information.




 



How can I mark visited links with a different color?

Go to Edit > Configuration > User Defined Stylesheet to open userContent.css from the current profile folder. Add the following with a color of your choice, save the CSS file, and restart the browser:





/* -- Links that have been visited are purple -- */
a:visited , a:visited * {color: purple !important;}




Colors can be any valid CSS format including hexadecimal (#cc00cc) or english color names. If it doesn't work, check if history is enabled or, in the case of word-colors, try other names or spelling in lower case (mediumvioletred). Other interesting link states: "a:hover" if mouse is over a link, "a:active" if a link was the last opened one.




 



How to stop K-Meleon from warning me about fonts not installed?

You must create a new pref entry in about:config. Go to Edit > Configuration > Browser Configuration or type about:config into the address bar. Right-click anywhere in the preferences list, and select New > Boolean. Name it font.askWhenNeeded and set the value to false.




 



How do I reverse the mousewheel direction for zooming?

The default direction for zooming with Ctrl+mousewheel depends on the version of the Gecko engine. That's why it switched between K-Meleon versions 1.5.4 and 1.6. 




You can reverse the direction for zooming by either manually changing preferences or using a macro. Visit the forum for more information and a macro that creates a simple menu entry to switch direction: http://kmeleonbrowser.org/forum/read.php?3,112080
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Why does website "X" not display/work properly? Is it a K-Meleon bug?

Probably not. In most cases it's just your Privacy & Security settings:




  	 Are you blocking Javascript? Many sites today insist on it. If blocked, they usually work only partly, or are completely empty, and a few even show funny reactions like redirecting you to their mobile version. Finetune your javascript settings in Edit > Preferences (F2) > Javascript, or toggle it in Tools > Privacy > Block Javascript, and try again.

	 Do you have blocked third-party Cookies (or all)? There are sites that insist in placing their ad-cookies in your browser. Try allowing "all" cookies, in Edit > Preferences (F2) > Privacy & Security, or toggle all-or-nothing in Tools > Privacy > Block Cookies.
	 You may also try toggling java, popups, referer etc., and if needed add certain sites to your personal exceptions list, see above.  




If that doesn't help and a site is still not displaying/working properly, it's normally caused by one of three issues:



  	 The site is not compliant with current HTML standards.
Try out how the site is looking in Internet Explorer (e.g. press Ctrl+Alt+I). Still a lot of websites use proprietary HTML markup and/or JavaScript code that only works correct in IE.
	 The site is using browser-specific JavaScript.
Try out how the site is working when you change K-Meleon's UserAgent string e.g. to Firefox' or SeaMonkey's. Still a lot of websites fail to detect K-Meleon as a Gecko-based browser. This is a typical problem in sites like Hotmail, Yahoo, Facebook, ...
You can change this in menu Tools -> User Agent -> and check Firefox 2 or Seamonkey 1.1 and reload the site.
	 The display problem is due to a Mozilla bug.
Try out how the site is looking in another Gecko-based browser e.g. Firefox or SeaMonkey.  




And more and more sites require the gecko engine 1.9.x to work fully, so they need K-Meleon 1.6 or newer. Currently (Nov.2010) this version is in development yet (Beta version), but many people use it already quite happy and such sites seem to work fine with it.




You can report such problems to the K-Meleon Forum - somebody may attempt to determine the source of the problem. Keep in mind that the particular authors are responsible for a website, not the K-Meleon developers.




 



Why can't I see the K-Meleon forum? It only shows an Error 403?

That infamous bug with a useless "technical support key" link?
That seems to be caused by ancient useragent strings, e.g. containing "Win98" or "Windows 98". Until it can be fixed, please use any other string. Either in menu Tools>User Agent, or open 'about:config' page and create this pref:

general.useragent.override (type STRING) 

An example value for faking IE7+XP: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)




 



Why is youtube now hanging at 23min?

Yes the mysterious youtube 23min bug, a prob that affects the whole Firefox family.

Workaround:  hit the left+right arrow keys to jump back 5 seconds.

Probably happens because youtube is now owned by Google. They now own several indispensable websites and services, and are frequently caught inserting little code snippets there which are non-standard, only coded for their own browser. If that causes glitches in other browsers, people will move over to use Google's Chrome. That trick works well of course, meanwhile they've reached an almost-monopoly for Chrome too. And due to this, most other website authors now also joined the train by coding exclusively for Chrome. Just like in the far past only for IE.




 



Since updating to a modern KM version it happens occasionally that a page doesn't fully load, stays all black, or still shows artefacts of the previous page mixed into the current one?

May have to do with hardware acceleration and Windows theme (forum example) 

Open this as adress and toggle the pref to true:

about:config?filter=layers.acceleration.disabled 

And this to false:

about:config?filter=layers.offmainthreadcomposition.enabled




 



Why can't I see that image, it works in other browsers?

Are "all" your images suddenly invisible? 



  	You have accidentally hit F9, the shortcut to toggle Tools > Privacy > Block Images. Use this menu or hit F9 again and reload. Actually this doesn't necessarily block "all" images, those in your exceptions list will still be shown.   




Only certain images broken, not all? 

If it's really not broken on the server, it's most likely your privacy settings:




  	 Click Edit > Preferences (F2) > Page Display, and tab "images". Have you checked "Load images from the original website only"? Uncheck it and reload.
	 Click on "Exceptions" and check if you have perhaps blocked the images from that domain.
	 Have you checked "Disallow scripts to change images"? Uncheck this and reload (needs also javascript). 
	 Do you have javascript blocked? Some images need this, try if it works if you allow JS in Tools > Privacy > Block Javascript (F7). Reload again.
	 Do you have ads blocked? The image could wrongly be blocked by the adblock stylesheet, a "false positive" due to its name, dimensions etc. Try if it shows with ads allowed: Tools > Privacy > Block Advertisement. If this helps and you want to permanently delete that false entry, things get a bit complicated: click Edit > Configuration > AdBlocking Stylesheet. This opens the file "AdBlock.css" in your profile folder, which you can edit.
	 If still nothing helps or you need help, just ask in the forum (general section).  




 



Why does K-Meleon forget my settings? (home page, bookmarks etc.)

Your settings will all be forgotten if you do not have writing rights in your profile folder. If you don't need a portable version and just want a quick fix: Delete the file "profile.ini" (not profileS.ini) in the K-Meleon program folder and restart. This will create a new profile in your user appdata folder, where you already have writing rights by default, and your settings will be remembered next time. More info here and here.




 



Why am I kicked out when using Backspace key in a input field (e.g. facebook wall)?

That happens on some modern sites when visiting them with older versions of the browser's gecko engine. Not all input fields are fully recognized as such anymore, and then "Go Back" is used instead of "Delete". A quick on-the-fly workaround is to press SHIFT+Backspace for deleting. For a permanent solution you can remove the default "Go Back" shortcut from the  "Backspace" key:

 Edit > Configuration > Accelerators

Add this line and restart:

 VK_BACK = 




(Notes: 
The above solution is just a profile setting, not global. Better but slightly more complicated: Remove that shortcut in all profiles by default and instead of "Backspace" use "SHIFT-Backspace" as shortcut for "Go Back". For this edit the file K-Meleon\defaults\settings\accel.cfg and change

VK_BACK = ID_NAV_BACK

into

#VK_BACK = ID_NAV_BACK

SHIFT VK_BACK = ID_NAV_BACK

By the way there's another default shortcut for flipping back pages: ALT+Left Arrow. Works fine, you just need both hands for it, unlike SHIFT+Backspace.)




 



Why does my personal firewall issue an alert that K-Meleon is requesting server rights?

The Personal Security Manager (PSM) in Mozilla, which K-Meleon is built on, uses sockets for communication between its security components. These communications are internal to the browser and do not go out to the Internet. There is no danger in allowing K-Meleon this access. All Mozilla browsers behave like that.




 



Why does K-Meleon refuse to run on my system?

Your system may be missing some "Microsoft runtime libraries required to run applications developed with Visual C++". Those dll's are not included in the ZIP/7Z versions of KM. Usually they exist already on newer systems, but uninstalling another program may have removed them. 




 KM 1.5.x needs: msvcp71.dll and msvcr71.dll 

Just put the 2 dll's into the K-Meleon root folder. You can download it from some DLL files download sites, like for example: DLL-files.com (or see below)




Unless you install the vcredist, you may find those dll's elsewhere in your programs folder or another computer, in internet dll-archives, or extract them from the "installer"-version of K-Meleon (e.g. with 7zip, instead of setup just right-click and unzip the exe).




 



Why is K-Meleon opening two windows or displaying a "Can't open..." error message when I open an URL from an e-mail program or an Internet Shortcut?

This type of problem is usually the result of the DDE (Dynamic Data Exchange) option being enabled in the Windows Registry for the type of URL that you are trying to open. In Windows Explorer, open Tools > Folder Options... and select the File Types tab. When you've found the type of URL in question (e.g. URL:HTTP ...), select it and click Edit.... In the list of Actions select open and click Edit.... Uncheck the Use DDE checkbox and press OK until you are finally out of the Folder Options dialog.




 



Why do the Bookmarks menu and/or other plugin menus not appear?

Your system is missing certain libraries. See the system requirements.

Also make sure that you have not accidentally disabled those plugins:

Edit -> Preferences -> K-Meleon Plugins. Click on the tabs for further configuration.




 



Why aren't links opening up in K-Meleon, it's set as my default browser?

The set-default routine in K-Meleon 1.5.x is outdated, it works only up to XP-SP2 correctly. If you're on a newer Windows you can use this autoit-extension for KM1.5.x: Defaulter2 (unzip with 7zip into K-Meleons root folder and restart)



(Or how to manually register "URL:HTTP(S)" filetypes:

Open up Windows Explorer and click the Tools button on the menu bar, then select Folder Options... In the Folder Options window select the File Type tab. Scroll down until you see "URL:HTTP (HyperText Transfer Protocol)" under the File Types column, it's extention is (NONE). Click the advanced button, then in the Actions: list box select open, then click the Edit button. In the new window click the Browse... button then navigate to the K-Meleon.exe in it's installed directory then click ok. The default location is "C:\Program Files\K-Meleon\K-Meleon.exe" (you can just copy this WITH QUOTES if you installed it in the default directory). Add "%1" to the The Application to preform action text box. Uncheck DDE and both Ok buttons. Do the same for the URL:HTTPS file type and then you're done.)




 



Why does the new Java Plug-In not work right?

The problem is Java's "Next Generation" plugin npjp2.dll. It seems to help to overrule that plugin with the "Classic" plugin: copy the file C:\Programs\Java\jre6\bin\npoji610.dll into K-Meleon's "plugins" folder (see forum). 




 



Where can I get more help?

Please review the release notes of the K-Meleon version you are using for known issues/problems.




Submit your question to the K-Meleon Forums (registration is not required to post and providing an e-mail address is optional). Be prepared that it may take some time until somebody knowing the answer to your question will read your post. So, check back from time to time. Bookmark the thread you posted to in order to find it again later. If you are registered, you can mark "Follow Topic" to find it listed in your 'Control Center', since currently there are no notifications by email. (Note: German language had a 'Blindflug' problem, set new Forum Language HERE.)




If you think you've found a bug, ask in the Forums first. 
Most posted "bugs" turn out to be just simple HowTo questions or general troubleshooting, like bugs in websites or third-party plugins, not K-Meleon bugs. In any case, make yourself familiar with our Bug Reporting Guidelines before you file a report in our Bug Tracking System (requires registration). Be prepared that you are asked to provide more information - you have to help us to help you.
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Miscellaneous


 



Where do I find the command to .... ?

  	...duplicate a tab?
	 Right-click the Go-Button, click "Open in New Page" (Ctrl+Alt+N)
	...open a text URL as link?
	 Select the full URL and hit the Go-Button. How it will open, in the same tab or a new one, depends on your settings for Selected Text
	...search for a selected text directly?
	 Select it and hit the Search button. Or right-click the button to choose another engine
	...translate a web page?
	 Click Tools > Translate. If you only need some lines, highlight them and Right-click > Translate
	...delete a stored password?
	 Edit > Preferences (F2) > Privacy & Security. There are the Password Manager and the Cookie Managers, for viewing, deleting and exceptions for single entries.  




 



Where do I find the configuration for .... ?

  	...XUL-based extensions, plugins, and Greasemonkey scripts
	 type about:addons into the address bar and press enter.  




  	...opening various stuff either in the same tab, new tab or background?
	 Edit > Preferences (F2) > Browsing. Check the dropdown menus in "General" and "Window Diversion". For link handling have a look here.  




  	...my home page(s) at startup?
	 Either in the menus, or simply right-click the "Home"-button to open a configuration menu. If at browser start you want to open several pages at once, choose "Start with Session...". You must have stored that session first: Open the pages you want at startup, then click Sessions > Save Session.  




  	...my profile path?  (aka 'Help my homepage doesn't stick' ;-)
	 Attention, you need writing rights in your profile folder, or your settings and bookmarks etc. will all be forgotten next time! (see here). To just find the current profile path, click Edit > Configuration > Profile Directory. If at setup you choose "multi-user" (default), your KM profiles are created in your windows user appdata account, where you already have writing-rights. This is best for most users. If instead you choose "single-user" they are created inside the K-Meleon root folder, wherever you put it. Most people choose the 'c:\programs' folder, but there you must allow yourself writing-rights manually (right-click folder and change "security", some machines need rebooting). To later switch profiles location, either remove or add an empty file named 'profile.ini' (no .txt ending) in the K-Meleon program folder. Fine-tuning, for experts only: profileS.ini in Profiles folder. See also above at setup profiles.  




  	...my email program or webmail?
	 Your default program is automatically found by clicking a mailto-link. To change it, right-click on the mail-button and "Configure...". Enter a program path or the URL of your webmail login. Check if a webmail site (yahoo) may require javascript, faking user-agent, more cookies etc.  




  	...automatic Find-in-Page?
	 To find a word in the current page, you can just start typing it out of the blue, no need to call the search function first. Find the configuration for this in  Edit > Page Search (Find-as-you-type / Start automatically / Search Links only)  




  	...the background image for toolbars?
	 Choose an image you like and save it as "back.bmp" in the folder of your current skin. It will show after next browser start if backgrounds are enabled. More info here: SkinsAndThrobbers.  




  	...certificates?
	 In menu Tools > Privacy > View Data > View Certificates. There are various tabs for configuration, editing, import, export, etc. For example on tab "Servers" you can add an exception if a site requires it and you find it trustworthy enough.  




 



What does "chrome" have to do with K-Meleon?

If by "chrome" you mean Google's new browser: Nothing! K-Meleon is 8 years older, and contained a "chrome" folder for its user interface long before Google even dreamed of creating an own browser and baptizing it "Chrome". To quote Wikipedia: "The visible graphical interface features of an application are sometimes referred to as 'chrome'". Regarding the Google browser it says: "The name is derived from the graphical user interface frame, or 'chrome', of web browsers."




 



 How did K-Meleon get started? 

K-Meleon has been around before Safari, Chrome, Edge, Pale Moon, or even Firefox showed up. Christophe Thibault started K-Meleon back when Mozilla was still distributing their internet suite that would later become SeaMonkey. The earliest versions of K-Meleon were simple and lightweight applications that used the embeddable Gecko engine. You can read more about the early history of the project on the History of K-Meleon page.




 



Are you crazy to jump from version 1.7 up to 74?!

To quote Dorian: Some websites only check the version number for compatiblity. With "k-meleon 2.0" they complain you must update your browser, but they are happy with "k-meleon 10.0". So, k-meleon 74 will be fine for a while...




 



Is K-Meleon dead?

Nope. Once again it was revived after a longer break. In Dec 2017 an independant developer (roytam1) joined K-Meleon and created a new fork, embedding the Goanna engine of PaleMoon27, itself a fork of Firefox. This works well, and still runs on XP, only a bit confusing that he kept the previous version number. Before stalling, K-Meleon76RC was already stable in 2016, just never declared as final release. Now this much advanced new Goanna-build (naturally KM77) is once again called K-Meleon76, like the last Gecko version. Just now K-Meleon GOANNA 76 (KM-Goanna76, KMG76, KG76). 




Since then, he's been posting weekly new builds! 

Here: KM-Goanna subforum 

Countless updates, mostly by importing github commits from related browsers like PaleMoon27 (now ended), Arctic-Fox, Waterfox, TenFourFox etc. His builds are unofficial, and will probably remain 'weeklies' forever, so don't wait for an official stable release. They are quite stable. Simultaneously roytam1 is also managing some other browser forks weekly, posted in the MSFN forum. The goal of his forks is to keep them as compatible as possible for old systems like XP. And like the 'upstream' browsers also to keep useful features which Mozilla ripped out, to keep xul addons working (Firefox legacy addons) etc. Since K-Meleon is sharing the same engine with his NewMoon27 for XP, both just get identic updates, except for GUI-stuff. Here's the catch:




He keeps improving the engine only, so be aware that the GUI has remained largely the same. With some important new features available under the hood, just still no user-interface for them. For example to block iframes, if you're not using a macro, you must now open "about:config" and create this pref yourself: "permissions.default.subdocument=1/2/3" (type INT: 1=allow, 2=block, 3=same domain)
Or type "about:about" in the urlbar to discover "hidden" features like the "about:addons" page, for managing installed Firefox xpi-addons. Or "about:downloads", etc. Some features can be made visible with additional macros from the forum, mainly to create menus etc.








More questions? 

You can post them in the K-Meleon Forum  (no registration and no e-mail address required). The "General" section is usually best for most sorts of questions.
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