Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
K-Meleon not accessing EBSCOhost dbs
Date: November 18, 2009 07:19PM

Has anyone experience with K-Meleon not being able to access EBSCOhost databases? We use KM on our public OPACs, and while it can access all of our other databases, it cannot open most of the EBSCOhost dbs, giving XML parsing errors instead (mismatched tag and duplicate attributes). I've tried entering the db URLs in the configuration menu as many different ways as possible. We've also tried updating KM to the most recent version, but this has not made a difference. I also opened a ticket with EBSCOhost technical help.

If anyone has troubleshooting tips on this I appreciate it.

(I'm sorry, I probably should have put this in general topics).

Edited 1 time(s). Last edit at 11/18/2009 07:56PM by librariansunshine.

Options: ReplyQuote
Re: K-Meleon not accessing EBSCOhost dbs
Posted by: disrupted
Date: November 18, 2009 08:27PM

this sounds like bad xmls in the DB, what's your km version?

if you're using the latest kmeleon, and to make sure it's a gecko thing, test with firefox 2.0 or seamonkey 1.8..if they display the same errors.. that means it;s a gecko problem(mostly there are errors in ebsco xml DB that gecko can not parse: not standard compatible.. that happens when people test or develop for internet explorer which is not using the correct standard for gecko).. there's no way to fix this from kmeleon's part and the errors have to be rectified in the DB itself, and only ebsco can fix..so you did the right thing by contacting their tech support.

if firefox or seamonkey don't have the same errors, then it's weird but this can mean a corrupted chrome (embed.jar).. in that case, reinstalling kmeleon should fix it.

also..if it's the first case, you can use the ie engine in kmeleon for ebsco db by using ietab extension which will most probably allow you access but you will have to enter the ietab chrome address first before the ebsco db url..for example, if their address is ebscohost.db etc you enter the chrome address first followed directly for nabisco url

if you like to test using ietab, download it from either km extensions central or jujuland extensions (if you don't know how to register components, then you should download from jujuland's because it uses a self-installer which automatically register components

km ext central: http://kmext.sf.net
jujuland extensions:http://extensions.geckozone.org/K-MeleonEn

Options: ReplyQuote
Re: K-Meleon not accessing EBSCOhost dbs
Posted by: guenter
Date: November 19, 2009 05:42AM

Also try with fake/spoofed UserAgentString Firefox!

They may have a minimum supported browser script with bugs.

Their loggin at http://search.ebscohost.com/ ?


Minimum browser requirements: Internet Explorer 6.0, Firefox 2.0, and Safari 2.0
Recommended minimum screen resolution: 1024x768

Which could IMHO indicate browser sniffing. And bugs in that are a FAQ.

Edited 1 time(s). Last edit at 11/19/2009 05:46AM by guenter.

Options: ReplyQuote

K-Meleon forum is powered by Phorum.