General :  K-Meleon Forum
General discussion about K-Meleon. 
How to activate autofill of login data?
Posted by: Zvonko
Date: March 05, 2018 09:46AM

Hi! This is essentially my old question, still unanswered ...

I have now here two KM builds installed -- let's call them KM I and KM II -- which I can use alternatively, with same profile and preferences. (The builds are KM 76 and KM76 Goanna.)

The problem refers to a https (ebanking) page.

In KM I the login data are autofilled after the page is loaded, just as I want it. This is the proof that the webpage allows such autofill.

In KM II the login data are not autofilled, but are displayed for selection when I click into the login field.

All relevant settings in preferences are equal: 'Remember login data' is activated, and the site is listed in Pasword Viewer / Saved password with correct username and password.

So there must be a setting issue which causes this different behavior... ???



Edited 6 time(s). Last edit at 03/05/2018 01:50PM by Zvonko.

Options: ReplyQuote
Re: How to activate autofill of login data?
Posted by: JamesD
Date: March 05, 2018 07:04PM

I think that the setting is not a browser setting, but a setting on the server. I usually run only one KM with only a single profile. Different sites act differently. Never had enough time to test before. Maybe I can now. I will report findings if I can find out why.

:::--------------------------
JamesD

Options: ReplyQuote
Re: How to activate autofill of login data?
Posted by: siria
Date: March 05, 2018 07:58PM

Quote
Zvonko
Hi! This is essentially my old question, still unanswered ...

It had gotten several answers just no solution yet, because you didn't reply to the last one anymore.

Quote
Zvonko
I have now here two KM builds installed -- let's call them KM I and KM II -- which I can use alternatively, with same profile and preferences. (The builds are KM 76 and KM76 Goanna.)

With "same" you mean you made the same manual settings?
Or sharing the same profile folder?
By the way the engines in KM76 and KM-Goanna are generations apart, it's also possible that the engine or different default settings has to do with your prob (Gecko 38 / Gecko 52-59)

Quote
Zvonko
In KM I the login data are autofilled after the page is loaded, just as I want it. This is the proof that the webpage allows such autofill.
In KM II the login data are not autofilled, but are displayed for selection when I click into the login field.

All relevant settings in preferences are equal: 'Remember login data' is activated, and the site is listed in Pasword Viewer / Saved password with correct username and password.

Well yes, the GUI is slightly limited, sometimes more prefs can be found in about:config
Filter for "signon".... that "autofill" one sounds suspicious?
I have a dim memory, that somewhere was a setting for autofilling FORMS, but can't find it anymore... Perhaps was another browser, no idea.

Perhaps also check on "about:preferences#security", if there are more options as in KM's native options?

And reading your other post, a wild guess, perhaps the prob is that KM now remembers 2 different logins for the same site and is confused? And the first one somewhere hidden in the depths of encrypted pw-files in the profile?

Options: ReplyQuote
Re: How to activate autofill of login data?
Posted by: Zvonko
Date: March 06, 2018 09:47AM

Quote
JamesD
I think that the setting is not a browser setting, but a setting on the server.

Hm ... as I wrote: "This is the proof that the webpage allows such autofill."

Quote
siria
With "same" you mean you made the same manual settings?

Usually when I am testing a new build installation I copy the whole Profiles folder from my KM used usualy.

But your suggestion referring to autofill in prefs was a SUCCESS!!! Although the same Profiles folder was copied to KM I and KM II, in KM II one setting was changed without my influence (obscure to me, but...). The correct setting is:
signon.autofillForms : true
With this setting my problem was solved!

My general conclusion to this problem:
The login-data autofill can be set
- via about:config > signon.autofillForms : true
- or by adding the line
user_pref("signon.autofillForms", true);
in prefs.js


I don't see where this could be set in the Preferences GUI.



Edited 6 time(s). Last edit at 03/06/2018 04:11PM by Zvonko.

Options: ReplyQuote
Re: How to activate autofill of login data?
Posted by: siria
Date: March 06, 2018 07:47PM

Quote
Zvonko
But your suggestion referring to autofill in prefs was a SUCCESS!!! Although the same Profiles folder was copied to KM I and KM II, in KM II one setting was changed without my influence (obscure to me, but...). The correct setting is:
signon.autofillForms : true
With this setting my problem was solved!

Glad to hear! Yes there should be a GUI, still missing. As for so many things (wish at least the most important permissions.default.xxx would show up in about:config)

The 'obscure' settings change is simply because the default setting seems to have changed between Gecko38 and 52/59. It probably was 'true' in older version, as you need it, so it wasn't ocntained in your prefs.js Because in user profiles are no default settings stored, only those which are different.
Visible with bold font (from user=prefs.js) or thin font (from default files) in about:config.
Therefore prefs.js is almost empty in new profiles yet.
When you manually define a setting with notepad in prefs.js, KM will read it at startup, but then automatically delete it from prefs.js again if the setting is identic to default.

To avoid this you can add important prefs to user.js instead.
This is always read and the values restored at startup by KM, but not changed. It's also possible to write comments inside this one.

By the way users always assume their custom settings were set in stone. They probably should, at least certain ones, but in reality extensions, addons, macros can do what they want with prefs. Changing prefs is actually one of the main jobs of them, necessary for the function, like different useragents. Everything gets stored in prefs. But have also seen 2-3 old macros which silently toggle on javascript, without telling the user or toggling back. Will not happen in my own ones, but opinions differ. But I like that macros are simple text, if anyone is interested they can simply look inside.



Edited 3 time(s). Last edit at 03/06/2018 08:17PM by siria.

Options: ReplyQuote
Re: How to activate autofill of login data?
Posted by: Zvonko
Date: March 07, 2018 09:51AM

Quote
siria
To avoid this you can add important prefs to user.js instead.

Fantastic! I tested this now. If the signon.autofillForms line is not present in prefs.js or if the value is set to false, but in user.js the line
user_pref("signon.autofillForms", true);
is added, this last setting becomes effective.

So your proposal seems to be an excellent idea to me!!! Users which are able to deal with user.js should add all their individual settings to this file. It would be a great benefit to me if I can always see on one place all my individual settings.

I will test this method extensively.



Edited 2 time(s). Last edit at 03/07/2018 09:53AM by Zvonko.

Options: ReplyQuote
Re: How to activate autofill of login data? (user.js, Startup Settings)
Posted by: siria
Date: March 07, 2018 02:21PM

Yes I remember those were my own feelings too, when finally discovering this important function grinning smiley
Unfortunately a few years too late, although it has always been in the menu:
Edit > Configuration > User Settings

But when I had explored KM for the first time and looked around the jungle of settings, I was a complete newbie yet, and even unfamiliar to Firefox or other Mozilla browsers. So at this exploring time user.js looked only confusing, quickly forgot about it again, and never looked back! Until some day stumbling about a tip on the web.
It would help a lot if it contained a little description out-of-box!
Today my file looks like that (also in KM/defaults/profile/)

Quote
user.js
user_pref("kmeleon.toolband.Throbber.visibility", false);

/* ----- DO NOT EDIT ANYTHING ABOVE THIS LINE -------------------------------------------- */

// difference prefs.js / user.js:
// KM will read this file but never WRITE below the "do not edit" line
// These are STARTUP prefs. During session they can be changed normally, but only until next start.
// Lines below are not deleted if identic to default values (which can change between KM versions)
// Comments are possible here. The line order is kept here.
// IMPORTANT: no syntax error, or the whole file is ignored! And at the end must be a linebreak.

user_pref("kmeleon.download.useSaveDir", false);
// javascript always OFF at startup:
user_pref("javascript.enabled",false);

PS: if you like playing with prefs, and some day need a tool for mass-toggling a bunch at once, and back again, or several different sets, take a look at my macro Blockeria ;-)


(sig) Brandnew K-Meleon 77 in development now!
(based on Goanna engine, own subforum, try TEST BUILDs)
K-Meleon FAQ (link missing in forum sidebar)
Tips&Tricks - Learning new stuff every day
New to K-Meleon? What do you like? What not?



Edited 1 time(s). Last edit at 03/07/2018 02:25PM by siria.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.